Widget tab order from Address Box to Search Box broken

VERIFIED DUPLICATE of bug 229100

Status

()

Firefox
Toolbars and Customization
VERIFIED DUPLICATE of bug 229100
14 years ago
12 years ago

People

(Reporter: Eamon McDermott, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

This has been a major annoyance to me for a while. When focus is in the Address
dropdown box, pressing tab will take you forwards to the Search box, however
pressing shift-tab will NOT take you back to the address box. This makes the UI
feel very broken, and makes the user resort to using the mouse to set focus back
to the Address box.

If this was intentional, is there any reason to inconvience the user so?

This is with the Default FireFox 0.8 theme.

Reproducible: Always
Steps to Reproduce:
1. Set focus with mouse in Address box
2. Press tab to move to Search box
3. Press shift-tab; focus will not return to Address box

Actual Results:  
Focus stays in Search box.

Expected Results:  
Focus should return to Adress box
(Reporter)

Comment 1

14 years ago
I also forgot to mention that this happens under both the Windows and Linux
builds of FireFox.

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 229100 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED

Updated

12 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.