Shift+keypad keys do not work in mail editor

VERIFIED FIXED

Status

--
minor
VERIFIED FIXED
15 years ago
14 years ago

People

(Reporter: ban, Assigned: mkaply)

Tracking

({verified1.7})

Trunk
x86
OS/2
verified1.7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.7b) Gecko/20040321
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.7b) Gecko/20040321

Starting from Mozilla 1.6, some Shift+keypad keys (namely Shift+Ins for paste
and Shift+arrows for selection) do not work in Mozilla Mail editor.

Reproducible: Always
Steps to Reproduce:
1. Launch Mozilla Mail and compose a new message
2. Try to paste something using Shift+keypad Ins
3. Try to select something using Shift+keypad arrows

Actual Results:  
Corresponding numerals are inserted when pressing shift+keypad keys.

Expected Results:  
Clipboard paste whet pressing Shift+keypad Ins, text selection when pressing
Shift+keypad arrows.

Comment 1

15 years ago
I don't use HTML mode, but WFM in text mode in same build.
Summary: Shift+keypad keys do not work in mail editor → Shift+keypad keys do not work in mail editor
(Assignee)

Comment 2

15 years ago
was numlock on or off?

Comment 3

15 years ago
Same both ways for me.
(Reporter)

Comment 4

15 years ago
(In reply to comment #2)
> was numlock on or off?

Numlock was off. If numlock is on, paste & selection works as expected.
(Assignee)

Comment 5

15 years ago
Is this happening with 1.7b?
(Reporter)

Comment 6

15 years ago
> Is this happening with 1.7b?

Yes. Shift+keypad keys work only when numlock is on.
(Assignee)

Comment 7

15 years ago
I see this. With numlock off I get 0.

Probably the new keyboard code.
Assignee: sspitzer → mkaply
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 8

15 years ago
Created attachment 146591 [details] [diff] [review]
Back out all of the new keyboard code

I give up.

I'm backing out all of Lee's keyboard code.

It broke too much stuff.
(Assignee)

Updated

15 years ago
Attachment #146591 - Flags: review?(pedemont)

Updated

15 years ago
Attachment #146591 - Flags: review?(pedemont) → review+
(Assignee)

Comment 9

15 years ago
Comment on attachment 146591 [details] [diff] [review]
Back out all of the new keyboard code

sr=blizzard (platform specific)
a=mkaply (Os/2 only)
Attachment #146591 - Flags: superreview+
Attachment #146591 - Flags: approval1.7+
(Assignee)

Comment 10

15 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Keywords: fixed1.7
Resolution: --- → FIXED

Comment 11

15 years ago
Verified as fix for the latest Mozilla 06-15 nightly build on WinXP.
Reporter/Dmitry, please reopen this bug if this is not working for your PC 
OS/2.
Status: RESOLVED → VERIFIED
Keywords: fixed1.7 → verified1.7
QA Contact: esther → karenlhuang

Comment 12

15 years ago
This has been marked as verified since verification has been done for both 1.7
branch & trunk 06-15 builds on WinXP.
Reporter/Dmitry, please reopen this bug if this is not working for your PC 
OS/2.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.