saving file with reserved filename freezes Firefox

RESOLVED WORKSFORME

Status

()

Toolkit
Downloads API
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: adam howard, Unassigned)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

A file named for a DOS/Windows reserved filename (lpt1, com1, etc) will cause
Firefox to freeze when you try saving it (at least when the mime type is
application/octet-stream). 

Reproducible: Always
Steps to Reproduce:
1. go to http://ecustomerdirect.com/com1
2. choose to save file to disk if it doesn't automatically


Actual Results:  
Firefox freezes

Expected Results:  
Since we can't save a file to disk with a reserved filename, we could handle it
more like Internet Explorer does. When you get the Save As dialog in IE, and
save the filename as com1, for example, it pops up a messagebox:

   com1
   This filename is a reserved device name. Please choose another name.
   OK

Comment 1

14 years ago
Worksforme with Firefox 20040425 on windows XP.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 2

14 years ago
oops, wrong bug.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 3

14 years ago
This WORKSFORME. Firefox shows that exact error message for me. Can you please
try it again with the latest nightly build and a clean profile?

ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/

Thanks.

Comment 4

14 years ago
A friend was able to reproduce this with 0.8 on his Windows XP Home SP1 system
(installer build). I was *not* able to reproduce this on my Windows XP Pro SP1
system with the 0.8 build (zip) or today's installer or zip builds.

Very odd....

Comment 5

14 years ago
I've been getting more reports of people being able to reproduce this bug, so
it's obviously happening even though I can't reproduce it. Leaving severity as
normal, since almost no one will hit this.

--> NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: hang

Comment 6

12 years ago
similar bug: 283822. maybe the same bug

Updated

11 years ago
QA Contact: ali → download.manager

Comment 7

11 years ago
(In reply to comment #6)
> similar bug: 283822. maybe the same bug

nothing to do with bug 283822

no freeze using trunk build) - comes back with dialog box of "download error" ... "cannot change the contents of that folder"
Assignee: bugs → nobody
WORKSFORME per comment 7
Status: NEW → RESOLVED
Last Resolved: 14 years ago10 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.