Closed Bug 238290 Opened 20 years ago Closed 20 years ago

-remote openURL doesn't work without specifying the url protocol

Categories

(Core Graveyard :: X-remote, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.7final

People

(Reporter: calvin441h, Assigned: caillon)

Details

(Keywords: regression)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040316
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040316

Remote control commands no longer work on mozilla 1.7b the same way they used to
with 1.6 and previous versions.

Reproducible: Always
Steps to Reproduce:
1.Launch mozilla and keep it open
2../mozilla -remote 'openURL(www.debian.org,new-tab)'
3../mozilla -remote 'openURL(http://www.debian.org,new-tab)'

Actual Results:  
After step 2.: I get a "Failed to send command" message.
After step 3.: The new tab opens successfully
Same results using "new-window" and "url" only instead of "new-tab".

Expected Results:  
Mozilla should load the url opening a new window or a new tab as it used to do
with previous versions.
Assignee: general → blizzard
Component: Browser-General → X-remote
QA Contact: general → blizzard
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attached patch FixSplinter Review
I tracked down what is going on here.  This is a regression from biesi's patch
to bug 183871, but darin is also somewhat at fault for introducing the codepath
to where the regression sparked.

Recently, as a patch to bug 226071, darin added MayOpenURL() which looked for a
scheme on the supplied URL.  If it didn't find it, it just tried to look for a
file: URL.  Biesi's patch which landed in 1.7alpha made it so you can't get a
relative file URL, which is what www.foo.com looks like since there is no
leading path information.

We should be using nsIURIFixup here, which has been specially designed by
rocket scientists to figure out what type of URL it really is.	Once we have
that info, we can proceed as normal.
Assignee: blizzard → caillon
Status: NEW → ASSIGNED
Attachment #144822 - Flags: superreview?(blizzard)
Attachment #144822 - Flags: review?(cbiesinger)
tested on linux/fc2 from gaim and xchat... appears to work.
Comment on attachment 144822 [details] [diff] [review]
Fix

looks good
Attachment #144822 - Flags: review?(cbiesinger) → review+
Attachment #144822 - Flags: superreview?(blizzard) → superreview+
Comment on attachment 144822 [details] [diff] [review]
Fix

Seeking approval to fix this xremote regression.
Attachment #144822 - Flags: approval1.7?
Comment on attachment 144822 [details] [diff] [review]
Fix

a=chofmann for 1.7
Attachment #144822 - Flags: approval1.7? → approval1.7+
Fix checked in 2004-03-26 13:44 PST.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Keywords: regression
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.7final
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: