[GTK2-only] Firefox crashes while opening this page

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: PeteVine, Assigned: Blake Ross)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040322 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040322 Firefox/0.8.0+

Either go the link above or start here:
http://www.olivebranch.com/isreal/galgoitha.htm 
and click on the Jerusalem link near the bottom of that page. Firefox crashes
whereas mozilla does not.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

14 years ago
I recompiled firefox with debug enabled and it no longer crashes showing a
dialog offering plugin download of the type audio/mid. So the lack of midi
plugin looks to be the cause of the crash. 
(Reporter)

Comment 2

14 years ago
I've just discovered only the GTK2 version of firefox is affected.

Updated

14 years ago
Summary: Firefox crashes while opening this page → [GTK2-only] Firefox crashes while opening this page

Updated

14 years ago
Keywords: crash

Comment 3

14 years ago
No crash here: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040329
Firefox/0.8.0+

I do NOT have a midi plugin, the download plugin dialog came up, no crash.
(Reporter)

Comment 4

14 years ago
As I wrote previously, the unstripped debug version doesn't crash either.
(Reporter)

Comment 5

14 years ago
Checked again today with:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040406 Firefox/0.8.0+
and don't see the crash any more.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 6

14 years ago
Created attachment 146353 [details]
Backtrace

This may be different bug, but I went to the URl specified, after
a longish delay some totally distorted sound appeared, and after 
pressing the back button, I got this crash.

Comment 7

14 years ago
Left off the Build ID:

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a) Gecko/20040417
Firefox/0.8.0+
You need to log in before you can comment on or make changes to this bug.