Cookie Manager slow when deleting multiple cookies

VERIFIED DUPLICATE of bug 226511

Status

()

Core
Networking: Cookies
VERIFIED DUPLICATE of bug 226511
14 years ago
14 years ago

People

(Reporter: Robert Schulz, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

The Cookie Manager is Mozilla 1.6 is very slow about updating it's self after I
have selected multiple cookies for deletion. Hangs so long that I'm almost ready
to shut Mozilla and when I recheck I find some of the cookies I wanted deleted
are still listed..  If this keeps up I'll have to go back to 1.5


Reproducible: Always
Steps to Reproduce:
1.Hold the control key + select multiple cookies to delete
2.Click the remove botton
3.Cursor changes to an hourglass and seems to hang there! 

Actual Results:  
Program will hang for like a 15 to 30 seconds or longer.
Will  find that not all selected cookies were deleted!

Expected Results:  
It should of updated right a way as has previous versions of Mozilla have worked.

This problem started from a fresh install using the default theme.
There have been improvements in speed recently. Can you try 1.7b?

Comment 2

14 years ago
The hang was fixed by bug 226511, the incomplete removal was fixed by Bug 231499.

So dupe of bug 226511?
no response from reporter, bug 226511 was a known perf regression that is fixed,
duping against that.  If we still have problems in 1.7b, please reopen.

*** This bug has been marked as a duplicate of 226511 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

14 years ago
(In reply to comment #3)
> no response from reporter, bug 226511 was a known perf regression that is fixed,
> duping against that.  If we still have problems in 1.7b, please reopen.
> 
> *** This bug has been marked as a duplicate of 226511 ***

Status: RESOLVED → VERIFIED

Updated

14 years ago
Summary: Cookie Manager is very slow responding when I delete multiple cookies at the same time. → Cookie Manager slow when deleting multiple cookies
You need to log in before you can comment on or make changes to this bug.