Composer doesn't insert DOCTYPE

VERIFIED FIXED in M15

Status

()

P3
normal
VERIFIED FIXED
19 years ago
17 years ago

People

(Reporter: Antti.Nayha, Assigned: Brade)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Overview Description:
  Composer doesn't insert a DOCTYPE in HTML documents.

Tasks to Reproduce:
  1. Start Composer.
  2. Write something.
  3. Choose Debug -> Output HTML and look at the output (or save the document
     and view it on a text editor).

Actual Results:
  The document begins with a <html> tag.

Expected Results:
  The document should begin with a Formal Public Identifier specifying the HTML
  version used, such as
  <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
   "http://www.w3.org/TR/html4/loose.dtd">

Builds and Platforms:
  2000-01-12-10 (Windows NT 4.0 SP6)
(Reporter)

Updated

19 years ago
Blocks: 7648
(Assignee)

Updated

19 years ago
Assignee: beppe → brade
OS: Windows NT → All
Hardware: PC → All
Target Milestone: M13
(Assignee)

Comment 1

19 years ago
reassign to myself; all platform/os; Setting to M13 since it's related to some
other stuff I'm working on.  However, it may not make the deadline due to some
recent complications.
(Assignee)

Comment 2

19 years ago
hey John! If you get ambituous you could add the doctype tag too :-)
This bug is related/similar to 22288
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M13 → M14
(Assignee)

Comment 3

19 years ago
move to M14; apparently this won't be quite as easy as the others
(Assignee)

Comment 4

19 years ago
*** Bug 16345 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Target Milestone: M14 → M15
(Assignee)

Comment 5

19 years ago
M15; this will need to wait for an api from vidur (post beta1)
(Assignee)

Updated

19 years ago
Depends on: 25020

Comment 6

19 years ago
This lack of a doctype is very serious. Pages from the composer don't validate
as HTML right now!
(Assignee)

Comment 7

19 years ago
this fix was checked in for today's builds
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 8

19 years ago
verified in 4/6 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.