Should skip X11 configure checks when building for Carbon or Cocoa

RESOLVED FIXED in mozilla1.7final

Status

RESOLVED FIXED
15 years ago
14 years ago

People

(Reporter: bryner, Assigned: bryner)

Tracking

Trunk
mozilla1.7final
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

15 years ago
I'm getting this bug report secondhand but it seems like an easy issue to
address.  Apparently we still check for X11 headers and libraries when building
for Carbon or Cocoa, and in some cases it's a fatal error when they aren't
found.  We can fix this simply by setting no_x=yes in the appropriate part of
configure.in.
(Assignee)

Comment 1

15 years ago
Created attachment 144598 [details] [diff] [review]
quick fix

Just to summarize the problem better:  this occurs if you install the X11 SDK. 
configure decides that you have X installed but it doesn't work correctly,
which is incorrectly made a fatal error.  Ideally we should be able to simply
skip the X11 checks for toolkit=mac|cocoa, but things are in the wrong order in
the script and I don't have time to figure out why (the X11 check is before the
toolkit option).  This patch just makes any X errors non-fatal if building for
mac/cocoa.
(Assignee)

Updated

15 years ago
Attachment #144598 - Flags: review?(cls)

Comment 2

15 years ago
Comment on attachment 144598 [details] [diff] [review]
quick fix

Ideally, there should be nothing wrong with checking for the presence of a
feature.  That's the entire philosophy behind autoconf.  These hardcoded
no_x=yes should be removed.  If we're doing an fatal X11 check in the wrong
spot then that should be fixed.
Attachment #144598 - Flags: review?(cls) → review-

Comment 3

15 years ago
Created attachment 144865 [details] [diff] [review]
only do fatal check when building for MOZ_X11

Btw, this problem isn't caused by the mere presence of the X11 SDK.  It has to
be present *and* broken to trigger the bustage.  You probably want to fix that
anyway	if you bothered to install it.

Updated

15 years ago
Attachment #144598 - Attachment is obsolete: true
(Assignee)

Updated

15 years ago
Attachment #144865 - Flags: review+

Updated

15 years ago
Attachment #144865 - Flags: approval1.7?

Comment 4

15 years ago
Comment on attachment 144865 [details] [diff] [review]
only do fatal check when building for MOZ_X11

a=asa (on behalf of drivers) for checkin to 1.7
Attachment #144865 - Flags: approval1.7? → approval1.7+
(Assignee)

Comment 5

15 years ago
checked in.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Updated

15 years ago
Target Milestone: --- → mozilla1.7final
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.