If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Problems clicking between two comboboxes on same page

VERIFIED DUPLICATE of bug 21405

Status

()

Core
XUL
P3
normal
VERIFIED DUPLICATE of bug 21405
18 years ago
18 years ago

People

(Reporter: Simon Fraser, Assigned: Patrick C. Beard)

Tracking

Trunk
PowerPC
Mac System 8.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
In composer, we have two combo boxes on the toolbar (paragraph type, and font
face). If you click on one of them to drop it down, then click on the other one
right away, then the first dropdown is succesfully dismissed, but the second
dropdown does not display correctly; it pops up behind the main window. You can
see this by making the window narrow enough that half of the right-hand popup
shows up outside the main window.

There is an additional redraw problem with these combo boxes, which is that the
part of the dropdown that is over the main content area fails to draw.

Comment 1

18 years ago
The behavior of 'eating' the event that should drop down the combobox is the
defined XP behavior by the combobox. If this is completely unacceptable, we
could add the "eating" of such events as an attribute in the nsILookAndFeel
object, thus making it configurable.

The dropdown paint issue is a known problem assigned to patrick.
(Reporter)

Comment 2

18 years ago
There isn't an event 'eating' problem that I can determine. The real problem is
that the popdown window (i.e. small native window) for the second combo box is
layered wrongly; it shows up *behind* the main window.

Comment 3

18 years ago
Oh, that problem is a view problem Patrick knows about.

Updated

18 years ago
Assignee: rods → beard

Comment 4

18 years ago
I can't find the duplicate bug, but this is a view issue - reassigning to beard

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 21405 ***

Comment 6

18 years ago
VERIFY duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.