Closed Bug 23849 Opened 21 years ago Closed 21 years ago

[CRASH][Regression]Selecting this attached message crashes application

Categories

(MailNews Core :: Backend, defect, P3)

defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 24008

People

(Reporter: fenella, Assigned: rhp)

Details

Linux (2000-01-13-08 M13)
Win_nt (2000-01-13-08 M13)
Steps:
1. Launch Messenger either using the -mail option or Task|Mail
2. From my Imap account Inbox, select the attached message,

Actual result: Status bar shows it downloads to about 3/4 of the way and then
Application crashes

Expected result: It should not crash, it should display the message with the
attachment.


This problem occurs on both Linux and Win32 today's build, but not yesterday's
build.
Have not tested Mac yet, today's Mac build is not out yet.
Assignee: phil → rhp
When I try to attach this message to the bug,  it gives a software error, even
though I save the message as an eml file and use mime type as message/rfc822.
So I am going to forward the message to Rich Pizzarro.
Reassign to rhp
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → WORKSFORME
I tried this with a new build with both local mail and IMAP and neither
crashed. Can you try this one again?

- rhp
QA Contact: lchiang → fenella
Status: RESOLVED → REOPENED
Linux Redhat 6.0 (2000-01-18-11 M13)
Win_nt 4.0 (2000-01-18-11 M13)
I try to re-test this bug using the following steps
1. I select this message, it still crashes when it loads 2/3 of the way as shown
in the status bar.
2. So I save this attachment to a tmp file
3. Create a new message and attach this file again
4. Send the new message to POP and IMAP.
5. Migrate a new profile POP and IMAP
6. Select the new message
Actual result: It still crashes 2/3 of the loading. Reopen the bug.
I should have the talkback report from LInux.
Resolution: WORKSFORME → ---
Hmm...I'm going to mark this as M14. It works on Win32 so if this is a Linux
specific problem, I'll have to get help from someone because I can't access an
IMAP server on Linux. Hmmm...I should set one up on my machine...in my spare
time ;-)

- rhp
Status: REOPENED → ASSIGNED
Target Milestone: M14
Hi Alec & Seth,
I'm copying you on this bug to see if you can help me out. I have tested this 
message (which I will post to the bug report) on Win32 (IMAP and mailbox:) and 
Linux (mailbox: only). I can't get it to crash so I'm guessing its an 
IMAP/Linux issue and I can't test this because I don't have IMAP access on my 
Linux machine.

Thanks!

- rhp
Doh! If I could read, I would have noticed that Fenella tried posting this and 
Bugzilla didn't like it. Fenella, can you forward a copy of this message to 
Alec and Seth.

Thanks one and all!

- rhp
Another data point for this problem is that this message is corrupted. If you 
look at the encoded attachment, you will see lines that are longer than 72 
characters long. This was an old sending bug that was fixed months ago, but we 
obviously shouldn't crash on display.

- rhp
we crash because in nsStorageStream::Write, we try to memcpy into mWriteCursor,
which is null.

a comment:  I noticed that in 4.x, we don't download this attachment when we
view the message, but in 5.0 we do.  I'm sure this is a known problem.  cc'ing
the imap gurus.

here's a stack trace:

#0  0x4032a8a7 in memcpy (dstpp=0x0, srcpp=0x42167f80, len=1533) at
../sysdeps/generic/memcpy.c:55
#1  0x4016516e in nsStorageStream::Write (this=0x41fb27e0, aBuffer=0x42167f80
"MWYxNSw1ZTk1DQptaWNyb3NvZnQucHVibGljLmZveC5mb3gyeC5zZXR1cC1lbnZpcm9ubWVu\ndCwsMSwzN2U4MWYxNSw1ZTk0DQptaWNyb3NvZnQucHVibGljLmZveC5mb3gyeC54cGxhdCws\nMSwzN2U4MWYxNSw1ZTk2DQptaWNyb3NvZnQucHVibGljLmZveC5oZW"...,
aCount=1533, aNumWritten=0xbffff084) at nsStorageStream.cpp:167
#2  0x41c34596 in MemCacheWriteStreamWrapper::Write (this=0x42101758,
aBuffer=0x42167f80
"MWYxNSw1ZTk1DQptaWNyb3NvZnQucHVibGljLmZveC5mb3gyeC5zZXR1cC1lbnZpcm9ubWVu\ndCwsMSwzN2U4MWYxNSw1ZTk0DQptaWNyb3NvZnQucHVibGljLmZveC5mb3gyeC54cGxhdCws\nMSwzN2U4MWYxNSw1ZTk2DQptaWNyb3NvZnQucHVibGljLmZveC5oZW"...,
aCount=1533, aNumWritten=0xbffff084) at nsMemCacheChannel.cpp:285
#3  0x41c2cdf5 in CacheOutputStream::Write (this=0x42101548, aBuf=0x42167f80
"MWYxNSw1ZTk1DQptaWNyb3NvZnQucHVibGljLmZveC5mb3gyeC5zZXR1cC1lbnZpcm9ubWVu\ndCwsMSwzN2U4MWYxNSw1ZTk0DQptaWNyb3NvZnQucHVibGljLmZveC5mb3gyeC54cGxhdCws\nMSwzN2U4MWYxNSw1ZTk2DQptaWNyb3NvZnQucHVibGljLmZveC5oZW"...,
aCount=1533, aActualBytes=0xbffff084) at nsCacheEntryChannel.cpp:75
#4  0x41c29d31 in InterceptStreamListener::write (this=0x42101730,
aBuf=0x42167f80
"MWYxNSw1ZTk1DQptaWNyb3NvZnQucHVibGljLmZveC5mb3gyeC5zZXR1cC1lbnZpcm9ubWVu\ndCwsMSwzN2U4MWYxNSw1ZTk0DQptaWNyb3NvZnQucHVibGljLmZveC5mb3gyeC54cGxhdCws\nMSwzN2U4MWYxNSw1ZTk2DQptaWNyb3NvZnQucHVibGljLmZveC5oZW"...,
aNumBytes=1533) at nsCachedNetData.cpp:1140
#5  0x41c29dba in InterceptStreamListener::Read (this=0x42101730, buf=0x42167f80
"MWYxNSw1ZTk1DQptaWNyb3NvZnQucHVibGljLmZveC5mb3gyeC5zZXR1cC1lbnZpcm9ubWVu\ndCwsMSwzN2U4MWYxNSw1ZTk0DQptaWNyb3NvZnQucHVibGljLmZveC5mb3gyeC54cGxhdCws\nMSwzN2U4MWYxNSw1ZTk2DQptaWNyb3NvZnQucHVibGljLmZveC5oZW"...,
count=1533, aActualBytes=0xbffff508) at nsCachedNetData.cpp:1128
#6  0x41a9e34f in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/mozilla/dist/bin/components/libmime.so
#7  0x40c86f9d in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/mozilla/dist/bin/components/liburiloader.so
#8  0x41c29f27 in InterceptStreamListener::OnDataAvailable (this=0x42101730,
channel=0x42104810, ctxt=0x0, inStr=0x8240fc0, sourceOffset=0, count=1533) at
nsCachedNetData.cpp:1112
#9  0x4060fe91 in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/mozilla/dist/bin/components/libnecko.so
#10 0x4060f2b7 in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/mozilla/dist/bin/components/libnecko.so
#11 0x401df36b in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/mozilla/dist/bin/libplds3.so
#12 0x401df27c in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/mozilla/dist/bin/libplds3.so
#13 0x4017547c in nsEventQueueImpl::ProcessPendingEvents (this=0x80ac0c0) at
nsEventQueue.cpp:228
#14 0x406caf84 in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/mozilla/dist/bin/libwidget_gtk.so
#15 0x406cac0f in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/mozilla/dist/bin/libwidget_gtk.so
#16 0x408823ca in ?? () from /usr/lib/libglib-1.2.so.0
#17 0x40883a86 in ?? () from /usr/lib/libglib-1.2.so.0
#18 0x40884041 in ?? () from /usr/lib/libglib-1.2.so.0
#19 0x408841e1 in ?? () from /usr/lib/libglib-1.2.so.0
#20 0x407ad7a9 in ?? () from /usr/lib/libgtk-1.2.so.0
#21 0x406cb587 in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/mozilla/dist/bin/libwidget_gtk.so
#22 0x4058f19d in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/mozilla/dist/bin/libnsappshell.so
#23 0x804bd0d in main1 (argc=1, argv=0xbffff8f4) at nsAppRunner.cpp:598
#24 0x804c197 in main (argc=1, argv=0xbffff8f4) at nsAppRunner.cpp:691
#25 0x402e3cb3 in __libc_start_main (main=0x804bf7c <main>, argc=1,
argv=0xbffff8f4, init=0x804a16c <_init>, fini=0x8050a58 <_fini>,
rtld_fini=0x4000a350, stack_end=0xbffff8ec) at
../sysdeps/generic/libc-start.c:78
Summary: [Regression]Selecting this attached message crashes application → [CRASH][Regression]Selecting this attached message crashes application
I presume we don't download this attachment in 4.5 'cause we have support for
mime parts on demand. We don't have that support in 5.0 yet.
yes, it's because we haven't done Mime Parts on Demand yet - it's post beta.
thanks for the info about mime parts.

to reproduce this, here is what I did.

exit 4.x, copy /u/sspitzer/bug23849 to ~/nsmail/bug23849
start up 4.x, copy that into an imap folder
exit 4.x

start up 5.0, go to your imap folder, click on that message.
This is the same crash as 24008. I'm checking in the fix shortly to the tip and 
the m13 branch.

I don't know if the fix will affect the attachment downloading though.

*** This bug has been marked as a duplicate of 24008 ***
Status: ASSIGNED → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → DUPLICATE
Mark as verified/dup.
Status: RESOLVED → VERIFIED
once warren checks in, I'll pull and test.
I just pulled and built with warren's fix, and the crash is gone.

nice work, warren.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.