McAfee antivirus incompatibility: quarantines whole Junk folder from under TBird.

RESOLVED DUPLICATE of bug 116443

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 116443
14 years ago
13 years ago

People

(Reporter: Ed Schiebel, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

I identified a mail message as junk.  Thunderbird is configured to automatically
move junk mail to the Junk folder.  When it did, my McAfee anti-virus software
detected a virus, determinted it couldn't clean the infected file, so
quarantined it.  This moved the Junk folder out from under Thunderbird.  After
that, I couldn't delete the Junk folder to recreate it, and Thunderbird couldn't
copy junk mail tere.

Reproducible: Didn't try
Steps to Reproduce:
1.
2.
3.



Expected Results:  
I would at least like to be able to delete the dangling reference to the Junk
folder and recreate it.  Ideally, Thunderbird would notice that the underlying
file(s) are gone and recreate them.
(Reporter)

Comment 1

14 years ago
It happened again tonight.

Comment 2

14 years ago
Ed - It seems like a bug in McAfee, not Thunderbird.

I'll leave the bug here; compatibility with McAfee would be nice.

Try closing thunderbird, deleting the junk folder manually in Explorer (if it's
still there) and recreating it manually.  If you need more help seek tech
support here:
http://forums.mozillazine.org/viewforum.php?f=39&sid=4386a18f58b32af3cfe34c9c8bc1c086


Revising summary for clarity and searching:
was:  anti virus scan quarantined junk mail folder.  can't access or delete this
folder now

now: McAfee antivirus incompatibility: quarantines whole Junk folder from under
TBird.
Summary: anti virus scan quarantined junk mail folder. can't access or delete this folder now → McAfee antivirus incompatibility: quarantines whole folder from under TBird.

Updated

14 years ago
Summary: McAfee antivirus incompatibility: quarantines whole folder from under TBird. → McAfee antivirus incompatibility: quarantines whole Junk folder from under TBird.

Comment 3

14 years ago
Hey, all antivirus programs do the same: I have Norton Antivirus corporate here,
and it deletes even my \\application data\thunderbird\mail\<account>\Inbox file,
if an email virus arrives... I updated the settings of the antivirus program,
but i'm not satisfied with this - mainly direct message write to disk is the
main problem.

Comment 4

14 years ago
(In reply to comment #3)
> mainly direct message write to disk is the
> main problem.

What alternative do you suggest?

AFAIK, Trend Micro's products don't have this problem, but somebody should
confirm that.
(Reporter)

Comment 5

14 years ago
I came up with a couple ideas for working around the symptoms, but then
realizsed that we need to solve the root-cause of the problem.  When McAfee
deleted the folder, it presented a message saying that it couldn't clean the
infected file and needed to quarantine it.  The real question is, why couldn't
McAfee clean the infected file?  Did Norton report a similar attempt also?

Comment 6

13 years ago

*** This bug has been marked as a duplicate of 116443 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.