Last Comment Bug 238509 - setting non-system dpi value causes scroll to alter glyphs drawing
: setting non-system dpi value causes scroll to alter glyphs drawing
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Layout: View Rendering (show other bugs)
: Trunk
: x86 Linux
: -- normal with 3 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
: 238508 (view as bug list)
Depends on:
Blocks: xft_tracking
  Show dependency treegraph
 
Reported: 2004-03-24 06:45 PST by Frederic Crozat
Modified: 2012-01-13 14:28 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Frederic Crozat 2004-03-24 06:45:19 PST
This is a follow-up of Mdk bug http://qa.mandrakesoft.com/show_bug.cgi?id=3152 :

when DPI is not set to default system dpi (for instance, settings DPI to 91,
either by using mozilla setting or using gnome-font-properties), scrolling some
webpages (for instance http://garoo.net/en/ ) might alter some lines (more
screenshot on the initial bug report). Just selecting one work on the corrupted
line correct the rendering.

Bug was initially reported on mozilla 1.4 xft/gtk2 but it is still present in
1.6final and 1.7 beta (tested on Mandrakelinux 10.0)
Comment 1 Frank Wein [:mcsmurf] 2004-03-24 07:16:06 PST
*** Bug 238508 has been marked as a duplicate of this bug. ***
Comment 2 Stefan Borggraefe 2004-03-24 09:06:30 PST
Dupe of bug 94739?
Comment 3 Zack Weinberg (:zwol) 2011-11-15 17:20:29 PST
Is this still a problem? We've made a whole lot of changes to DPI handling since 2004.
Comment 4 Jeff Muizelaar [:jrmuizel] 2012-01-13 14:28:53 PST
I'd be very surprised if we were still affected by this.

Note You need to log in before you can comment on or make changes to this bug.