All users were logged out of Bugzilla on October 13th, 2018

{inc}The size of the middle column is incorrect until I reload or I change the font size

RESOLVED FIXED

Status

()

RESOLVED FIXED
15 years ago
12 years ago

People

(Reporter: k_guillaume, Unassigned)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040316
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040316

In http://abaserv.dyndns.org/adn/page.php?textfile=nde_pc_aae , the three
columns should have the same height. With Mozilla 1.7b , Firefox 0.8 , and other
older version of navigator using Gecko, running on GNU/Linux on x86 or PPC,
windows, or Mac OS X, the page is incorrectly rendered when it's loaded for the
first time, but is correctly rendered when I click on the reload button, or when
I change the font size with CTRL + or CTRL - , or with the View menu. Once the
layout is correct, it stay correct, until I reload the page with MAJ + Reload
button.

Reproducible: Always
Steps to Reproduce:
1. Load http://abaserv.dyndns.org/adn/page.php?textfile=nde_pc_aae
2. Look carefully at the middle column, both on the top of the page and at the
bottom : the layout is incorrect.
3. Reload it with the reload button, or change the font size for a bigger one
then back to the previous, or any other font size.
4. The layout is now correct.
5. To get the problem again, reload the page using MAJ + reload button.
Actual Results:  
The middle column is shorter than expected and incorrectly placed.
The top of the page shows misalignement.

Expected Results:  
The correct result is the one you get after you reload the page without pressing
MAJ, or after you change the page font.
Top and bottom of the page are aligned.

Comment 1

15 years ago
I'm no expert in layout, but looking into the source of that page I see a table
with three columns. For the left and right columns the height is set to 100%,
but for the center column this attribute is not set. I don't know how Mozilla
handles this, but for the author of the page it should be an easy fix.
(Reporter)

Comment 2

15 years ago
Using height=100% in the middle column and in the first table inside this middle
column seems to have corrected the top of the page, but the bottom of the page
still present disalignement during the first rendering, apparently due to
improper  height calculation. Reloading the page (without MAJ) still result in
the correct layout to be displayed.
This bug needs a minimal testcase attached to the bug.
Keywords: qawanted
Summary: The size of the middle column is incorrect until I reload or I change the font size → {inc}The size of the middle column is incorrect until I reload or I change the font size
(Reporter)

Comment 4

15 years ago
Created attachment 145431 [details]
This is the html source and depandencies of the URL demonstrating this bug. The bug doesn't appear when loading it with file://

I tried to download the html page source, linked images, and the css, localy on
my hard drive, and then view the result opening the local file with file:// ...

The result is correct, so maybe this bug is related to rendering while http
download.

Attached is the page and dependencies, which display fine when loaded from the
local file system, but incorrectly when downloaded by http.
Right now I don't have access to an http server, so I can't reduce the code
into a minimal form demonstrating the problem. Maybe I'll install one to do the
work when I've some time.

Comment 5

15 years ago
Created attachment 147675 [details]
image for testcase

Comment 6

15 years ago
Created attachment 147676 [details]
testcase
Attachment #145431 - Attachment is obsolete: true

Comment 7

15 years ago
Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: qawanted → testcase
Created attachment 147741 [details]
testcase

This is slightly clearer since it has zero cellpadding/cellspacing.

It looks like the incremental reflow when the placeholder is replaced by the
image doesn't change enough.
Attachment #147676 - Attachment is obsolete: true
With most recent testcase, I see the height change on reload with:
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006120606 Minefield/3.0a (pre-reflow branch)

With same testcase, I see no height change on reload with:
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006120804 Minefield/3.0a1 (post-reflow branch)

--> RESOLVED FIXED?

Comment 10

12 years ago
Works in Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a1) Gecko/20061209 Minefield/3.0a1, marking fixed.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.