iafdb.travel.state.gov - The find location dialog will not respond to the "Search" button

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
14 years ago
3 years ago

People

(Reporter: David Eccleston, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316

US Dept of State Passport services page, find a location to apply at.
Choose to search by zip code and type in a zip.
When you push the "Search" button, it just sits there instead of displaying
locations.

Looking at source for page, this looks like it was written in JavaScript.

Choosing to search by State/City works.  Everything works in internet explorer.

Reproducible: Always
Steps to Reproduce:
1.Browse to http://iafdb.travel.state.gov/
2. Choose Search By Zip Code
3. Enter Zip Code
4. Press "Search" button.
Notice that nothing happens.

Actual Results:  
Nothing happens.

Expected Results:  
Should have been taken to list of zip codes.

Comment 1

14 years ago
This page uses document.all all over the place... I can't believe an US
government page forces their users to use a certain proprietary browser. :-(

Over to Tech Evangelism.
Assignee: general → english-us
Status: UNCONFIRMED → NEW
Component: JavaScript Engine → English US
Ever confirmed: true
OS: Windows XP → All
Product: Browser → Tech Evangelism
QA Contact: pschwartau → english-us
Hardware: PC → All
Version: Trunk → unspecified

Updated

14 years ago
Summary: The find location dialog will not respond to the "Search" button → iafdb.travel.state.gov - The find location dialog will not respond to the "Search" button

Comment 2

4 years ago
Seems fixed.
[closeme]
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.