META refresh happens immediately rather than after a period of time

RESOLVED DUPLICATE of bug 121716

Status

()

RESOLVED DUPLICATE of bug 121716
15 years ago
15 years ago

People

(Reporter: jcave, Assigned: darin.moz)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316

The Washington Post main page http://www.washingtonpost.com contains the META tag

<META HTTP-EQUIV="refresh"
CONTENT="900;url=http://www.washingtonpost.com/?LOAD_PAGE&reload=true"> 

It appears that this is causing Mozilla 1.7 to continuously refresh the page. 
Previous builds, and other browsers, will refresh the page every 15 minutes.

Reproducible: Always
Steps to Reproduce:
1.Go to http://www.washingtonpost.com
2.Note that the page continuously refreshes
3.

Actual Results:  
The page continuously refreshes

Expected Results:  
The page should refresh after 15 minutes, as specified in the META refresh tag

Comment 1

15 years ago
Works fine for me, Mozilla 1.7b WinXP.
What if you create a new Mozilla profile? Does it still happen then?

Comment 2

15 years ago
WFM, too (FF 0.8 and Moz. 1.7b)

however, they do have a javascript included (suspiciously called
"autorefresh.js") that seems to alter the meta-refresh. maybe, it is behaving
evil under certain circumstances?
--> http://media.washingtonpost.com/wp-srv/homepagessi/autorefresh.js
(Reporter)

Comment 3

15 years ago
I just double-checked that the problem still appears for me (Mozilla 1.7b 
Windows XP Professional).  Creating a new profile does not change the behavior--
 the page constantly refreshes.

It appears that Christian's comment about Javascript is correct.  If I disable 
Javascript, the refreshes cease.  Thus, it appears that the Javascript, not the 
META tag is what is causing Mozilla problems.  

Should I change the summary and affected component of this bug, or would it be 
better to close it and open a new one?

Comment 4

15 years ago

*** This bug has been marked as a duplicate of 121716 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.