If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

The above URL will crash Mozilla and Firefox without error message.

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Paul Gillingwater, Unassigned)

Tracking

({crash})

Trunk
x86
Windows XP
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316

This appears to be a bug, which when faced with some non-conformant HTML, causes
both Mozilla 1.7b and Firefox 0.8 to crash silently without an error message.

Reproducible: Always
Steps to Reproduce:
1. Go to the above link
2. Watch it crash
3. ????
4. Pofit

Actual Results:  
The page starts to display, but then suddenly crashes.  No more Mozilla in memory.

Expected Results:  
Displayed the Web page.

Theme is Classic.  I'm using Talkback, but it didn't talk to me.
(Reporter)

Comment 1

14 years ago
http://www.theage.com.au/articles/2004/03/25/1079939783247.html is the URL which
caused this crash.  I have seen many other similar URLs with the same effect.

Comment 2

14 years ago
Works fine for me, Mozilla 1.7b WinXP. Does it still crash for you if you create
a new profile?
(Reporter)

Comment 3

14 years ago
As suggested, I created a new test profile -- and sure enough, the crash is
still consistent.  Can anyone suggest how I can capture the cause of this crash?

Comment 4

14 years ago
WORKSFORME Mozilla 1.7b 2004032208 XP Pro SP1
but I note 179 markup errors (including many invalid elements: <HEADLINE>,
<BOD>, <ISLANDAD>), 20 nested tables and several inline <script> to be executed
as the page loads (even 1 in an iframe). CPU and RAM usage numbers as the page
loads are normal over here. No error in the javascript console. Otherwise
nothing special to report.
It also WORKSFORME with Firefox 0.8 build 20040206.

Comment 5

14 years ago
Try removing Mozilla (the program, not the profile) from your harddisk and
install again. It'll free you from all sorts of plugins and other stuff that
could be causing this.

You can capture this crash if you have debug build but since you asked the
question I assume you don't have one.
(Reporter)

Comment 6

14 years ago
Actually, this is a fresh install of Mozilla (downloaded and installed today.) 
Previously, I have been using Firefox, which exhibits the same behaviour
(crashing the browser without warning on some pages.)

I think I have the debug version of the Mozilla browser--at least the menu says
Debug, but the build option suggests otherwise (see below).  I am willing to
download a debug build if one exists.

about:buildconfig

Build platform
target
i586-pc-msvc

Build tools
Compiler 	Version 	Compiler flags
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TC -nologo -W3 -nologo -Gy -Fd$(PDBFILE)
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TP -nologo -W3 -nologo -Gy -Fd$(PDBFILE)
-I/usr/X11R6/include

Configure arguments
--without-system-jpg --without-system-zlib --enable-extensions=default,irc,tasks
--enable-crypto --disable-auto-deps --disable-debug --enable-optimize=-O1

Comment 7

14 years ago
> I think I have the debug version of the Mozilla browser--at least the menu says
Debug

Well, that's a no ;) Debug builds are hand made by compiling the source
yourself. Additional files are created during the process that can be used by a
debugger to step through the code and show a stacktrace. They are not available
for download. The Debug menu is available in all nightlies. It is removed from
releases. Can you post some more urls that crash consistently?

Updated

14 years ago
Keywords: crash

Comment 8

14 years ago
WFM
Maybe try reinstalling your JRE?

Comment 9

14 years ago
does it crash if you remove your flash plugin?
(Reporter)

Comment 10

14 years ago
Regarding the question of whether Flash disabled will cause a problem -- with
Firefox, I am using the "Click to Display Flash" option, which means that Flash
won't run on this page -- but it will still crash the browser.

Incidentally, how can I quickly disable Flash, to test this with Mozilla?

Comment 11

14 years ago
just move the plugin out of the plugin directory?

Comment 12

14 years ago
WFM

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040321
Firefox/0.8.0+

Updated

14 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.