Bad content from server eats up memory and crashes

VERIFIED WORKSFORME

Status

()

P3
critical
VERIFIED WORKSFORME
19 years ago
19 years ago

People

(Reporter: dshea, Assigned: gagan)

Tracking

({crash})

Trunk
x86
Windows 98
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
1. Using netcat (or some other socket utility) create a listening tcp socket on
port 80.
c:\nc -l -p 80
2. Use mozilla to connect to the machine with the listening port.
http://<hostname>
3. Netcat will receive the GET request, and now you respond by sending 'A's.
c:\nc -l -p 80
GET / HTTP/1.0
host: tdcoolv
user-agent: Mozilla/5.0 [en-US] (Windows_98; I)
accept: */*

AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA    [this is what you type.]
[hit return twice]

RESULTS
Connection completes. Mozilla is frozen.  On my machine, the cpu is busy eating
up all memory (physical and virtual disk memory) until it eventually crashes.
"Mozilla caused an invalid page fault in module XPCOM.DLL at 015f:60be09d0"

NOTES
Contact me if you need help reproducing.  If possible, I'd like to know if this
is caused by a buffer condition.
(Reporter)

Comment 1

19 years ago
Created attachment 4230 [details]
netcat - client connect and socket listen utility
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

19 years ago
Nice catch Dylan! cc'ing rpotts.

Updated

19 years ago
Severity: normal → critical

Updated

19 years ago
Target Milestone: M14

Comment 3

19 years ago
Adding "crash" keyword to all known open crasher bugs.
Keywords: crash

Updated

19 years ago
Keywords: beta1

Comment 4

19 years ago
PDT+
Whiteboard: [PDT+]
(Assignee)

Comment 5

19 years ago
Dylan where can I get more info about running netcat? thx. 
(Reporter)

Comment 6

19 years ago
I've attached the Win32 version of netcat to this bug record.
C:\netcat -h
will give you info on how to run netcat.
The unix (and windows) version of netcat is available here...
http://www.l0pht.com/~weld/netcat/
(Assignee)

Comment 7

19 years ago
argh... this has suddenly stopped crashing for me now. I am not sure what fixed
it but I can't dup it anymore. Marking as worksforme. Pls. reopen if it happens
again-- my suspicion is that we were perhaps doing some release (in XPCOM) that
might have recently been fixed. 
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 8

19 years ago
Worksforme too
marking verified:
Win98 build 2000022708
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.