Closed Bug 238650 Opened 16 years ago Closed 16 years ago

Duplicate of self error should be less insulting

Categories

(Bugzilla :: User Interface, defect, trivial)

defect
Not set
trivial

Tracking

()

RESOLVED FIXED
Bugzilla 2.18

People

(Reporter: timeless, Assigned: apeiron)

Details

Attachments

(2 files, 1 obsolete file)

160   [% ELSIF error == "dupe_of_self_disallowed" %]
161     [% title = "Nice Try..." %]
162     Nice try, [% user.login FILTER html %], but it doesn't
163     really make sense to mark [% terms.abug %] as a duplicate of itself,
164     does it?

I'm willing to maintain en/insulting/ if people want, but i think en/default
should be nicer. or at least consistent. this is the only error in the file
which is so brazen.
I'm okay for changing the message. Something bland like 

  Bugs cannot be marked as duplicates of themselves.

might work?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Yeah, I'm okay for changing that, too.  It's one of the leftovers from all the
inside jokes at Netscape ;)
Severity: normal → trivial
OS: Windows XP → All
Hardware: PC → All
Target Milestone: --- → Bugzilla 2.18
Assignee: myk → apeiron
Comment on attachment 144760 [details] [diff] [review]
Here's a patch. Fixed to 1. use cvs diff 2. use terms.abug

You need to use terms.abug in the title too.
Attachment #144760 - Flags: review-
Comment on attachment 144760 [details] [diff] [review]
Here's a patch. Fixed to 1. use cvs diff 2. use terms.abug

Index: user-error.html.tmpl
===================================================================
RCS file:
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/user-error.html.t
mpl,v
retrieving revision 1.53
diff -u -r1.53 user-error.html.tmpl
--- user-error.html.tmpl	18 Mar 2004 21:51:18 -0000	1.53
+++ user-error.html.tmpl	25 Mar 2004 20:02:18 -0000
@@ -158,10 +159,8 @@
     [%+ terms.bug %] is a duplicate.  The [% terms.bug %] has not been
changed.

   [% ELSIF error == "dupe_of_self_disallowed" %]
-    [% title = "Nice Try..." %]
-    Nice try, [% user.login FILTER html %], but it doesn't
-    really make sense to mark [% terms.abug %] as a duplicate of itself,
-    does it?
+    [% title = "Cannot mark [% terms.abug %] as a duplicate of itself" %]
+    You can't mark [% terms.abug %] as a duplicate of itself.

   [% ELSIF error == "email_change_in_progress" %]
     [% title = "Email Change Already In Progress" %
Attachment #144760 - Attachment description: Here's a patch. → Here's a patch. Fixed to 1. use cvs diff 2. use terms.abug
Attachment #144760 - Flags: review?
Whoops, somehow I managed to make a comment out of the fixed patch. It's an
attachment now.
Attachment #144760 - Flags: review?
Attachment #144784 - Flags: review?(kiko)
Attachment #144784 - Flags: review?(kiko) → review+
I personally don't think this is insulting at all - I think it shows that
Bugzilla has a sense of humour... but if you really want to get rid of it, I
won't jump up and down about it.

Gerv
Flags: approval?
Flags: approval? → approval+
Summary: Please stop insulting me when I make an honest mistake → Duplicate of self error should be less insulting
Comment on attachment 144760 [details] [diff] [review]
Here's a patch. Fixed to 1. use cvs diff 2. use terms.abug

Obsoleting obsolete patches.
Attachment #144760 - Attachment is obsolete: true
Checking in template/en/default/global/user-error.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/user-
error.html.tmpl,v  <--  user-error.html.tmpl
new revision: 1.58; previous revision: 1.57
done
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Comment on attachment 144784 [details] [diff] [review]
This patch fixes the title of the previous one.

Breaking the tree is bad.
Attachment #144784 - Attachment is obsolete: true
Attachment #144784 - Flags: review-
Attachment #144784 - Attachment is obsolete: false
Ouch. Sorry I didn't catch that.
Comment on attachment 144932 [details] [diff] [review]
Okay, this should fix it.

Checking in template/en/default/global/user-error.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/user-error.html.t
mpl,v  <--  user-error.html.tmpl
new revision: 1.59; previous revision: 1.58
done
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.