"in size" is awkward (both times) in "patch_too_large" error

RESOLVED WORKSFORME

Status

()

Bugzilla
User Interface
--
minor
RESOLVED WORKSFORME
14 years ago
5 years ago

People

(Reporter: timeless, Assigned: myk)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
598   [% ELSIF error == "patch_too_large" %]
599     [% title = "File Too Large" %]
600     The file you are trying to attach is [% filesize FILTER html %] 
601     kilobytes (KB) in size.
602     Patches cannot be more than [% Param('maxpatchsize') %] KB in size.
603     Try breaking your patch into several pieces.

correcting this is left as an exercise to the patcher

Comment 1

14 years ago
Created attachment 144772 [details] [diff] [review]
Here's one patch for this.

This patches one part of the file; another one will patch a separate part.

Comment 2

14 years ago
Created attachment 144775 [details] [diff] [review]
Here's the other one.

Note, one of these covers the area mentioned in the bug, and the other covers
another area. This one covers the area mentioned.

Updated

14 years ago
OS: Windows XP → All
Hardware: PC → All
(Reporter)

Comment 3

14 years ago
that's one way, i was wondering if replacing 'in size' with 'large' or 'big'.
i'm not really sure though :).

Comment 4

13 years ago
There's nothing grammatically wrong with 'in size' in either instance here.

Besides that, you filed another bug on a different part of this very same error 
message about 25 minutes before filing this one. I know that it's a different 
line number, but MHO is that this is cutting things a little too fine.

DUPEing this one to that one, as I'm re-writing most of the error message over 
there, so we can wholistic changes all at once, if need be, rather than word-by-
word.

*** This bug has been marked as a duplicate of 238667 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 5

13 years ago
Argh, okay, I'm an idiot. I missed that this was a different user-error than 
238667 until the DUPE notice came up on ssdbot in IRC. That one is for 
file_too_large, and this one is for patch_too_large.

So, this isn't a dupe. The fact remains, though, that there's nothing 
grammatically incorrect with having 'in size' here. Marking WORKSFORME.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

13 years ago
it's awkward!

Comment 7

13 years ago
To you, saying "500 KB in size" is awkward.

To me, saying "500 KB large" or "500 KB big" (comment #3) is an abomination of 
the English language.

My point is that, unlike many of the other similar bugs you filed on this date 
(were you really bored that night, or what? :) this one is grammatically sound, 
and there's no semantic reason to change it. It's just a matter of personal 
preference; you don't like the way '500 KB in size' sounds to your ear, but 
others have no problems with it. (I happen to like it.)

Hence, WORKSFORME.
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.