bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

'resolve the bug' feels awkward in "resolving_remaining_time" error

RESOLVED FIXED in Bugzilla 2.20

Status

()

Bugzilla
User Interface
--
minor
RESOLVED FIXED
15 years ago
6 years ago

People

(Reporter: timeless, Assigned: Shane H. W. Travis)

Tracking

unspecified
Bugzilla 2.20

Details

(Whiteboard: subsumed by bug 283139)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
649   [% ELSIF error == "resolving_remaining_time" %]
650     [% title = "Trying to Resolve with Hours Remaining" %]
651     You cannot resolve [% terms.abug %] with hours still remaining.  Set
652     Remaining Hours to zero if you want to resolve the [% terms.bug %].

should this say 'this [% terms.bug %]'?

Comment 1

15 years ago
Created attachment 144780 [details] [diff] [review]
Here's one suggested method of patching this.

This patch uses terms.abug because it implies a more general, "this is a rule"
feeling to the message. An opposing view is to use "this", which IMO labels
this particular bug and no others to be effected by the rule. Stating the
general rule if applicable is better in my opinion because it should serve to
prevent future violations of the rule.
(Reporter)

Comment 2

15 years ago
Comment on attachment 144780 [details] [diff] [review]
Here's one suggested method of patching this.

>+    You cannot resolve [% terms.abug %] because it has hours still remaining.

better "still has hours remaining"

>+    Set Remaining Hours to zero if you want to resolve the [% terms.bug %].

i wonder, should |Remaining Hours| be marked up in some manner?
note that this second line seems to indicate to me that one doesn't need to
select (*) resolve bug as [fixed|v], i.e. simply setting remaining hours to 0
will do something like that for you. i wonder if that's the case :)
(Assignee)

Comment 3

14 years ago
Comment on attachment 144780 [details] [diff] [review]
Here's one suggested method of patching this.

There is no 'Remaing Hours' field; what there is is a [%
field_descs.remaining_time %] field, which was changed fairly late in the
process, so it probably never got changed in this error message.

Given that, you'll probably need to say something more generic, which more
accurately describes the error-checking being done for this... something like,
"You cannot resolve (abug) unless the (f_d.r_t) field is '0'."

On a wider issue, this is a prime example of an annoying error, IMHO. The user
has said that he wants to resolve the bug, but now this little 'gotcha!' sneaks
up and flashes a red screen at him. Now he has to hit the 'back' button --
which has the possibility of emptying the entire page (bug 36843) -- in order
to fulfil the requirements of this little check. 

If you know that it has to be 0 on resolve, and the user has said he wants to
resolve, why not just be nice and set it to '0' on his behalf? After all, which
is more likely - that the user is going to accidentally hit 'resolve' with time
left, and be thankful that this error-check saved him from going to an
incorrect state... or that the user is going to correctly hit resolve with time
left, and is going to be mightily peeved by this error?

Yeah, okay, this is way off topic... but I think I'm going to open up a bug on
the issue, which will render this one irrelevant.
Attachment #144780 - Flags: review-

Comment 4

14 years ago
Yes, I fully agree with travis. Open a bug and CC me, please! And IMO, there is
no need to reset the remaining time to zero, let it as it is.... For historical
reasons, you can then see what you still had...
(Assignee)

Comment 5

14 years ago
This error message goes away completely once the patch to bug 283139 lands, so 
I'll close this bug at that time.
Assignee: myk → travis
Status: UNCONFIRMED → NEW
Depends on: 283139
Ever confirmed: true
Whiteboard: subsumed by bug 283139
Target Milestone: --- → Bugzilla 2.20
(Assignee)

Comment 6

14 years ago
Now that bug 283139 has landed, and the resolve_remaining_time error message 
has been completely removed, from the user-error.html.tmpl file, this bug is 
being marked FIXED.

You gotta admit, the phrasing is no longer awkward... ;-)
Status: NEW → RESOLVED
Last Resolved: 14 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.