If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

conditional QA contact text not appearing

RESOLVED WORKSFORME

Status

()

Bugzilla
Creating/Changing Bugs
RESOLVED WORKSFORME
14 years ago
5 years ago

People

(Reporter: Tom Karzes, Assigned: myk)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

In the "edit bug" template (bug/edit.html.tmpl), there is some conditional text
which is intended to mention the QA contact if "useqacontact" is enabled.  I
believe the check is failing.  The template excerpt looks like:

      <input type="radio" name="knob" value="reassignbycomponent">
      Reassign bug to owner
      [% "and QA contact" IF useqacontact %]
      of selected component

I believe useqacontact should be Param('useqacontact') as shown below:

      <input type="radio" name="knob" value="reassignbycomponent">
      Reassign bug to owner
      [% "and QA contact" IF Param('useqacontact') %]
      of selected component

Currently, I don't believe the "and QA contact" text ever appears, even if
"useqacontact" is enabled. Not that there's that much difference, or that it's
even that important a distinction -- my main gripe is that the template code
isn't doing what it was intended to do.


Reproducible: Always
Steps to Reproduce:
1. Enable the "useqacontact" parameter.
2. Edit an open bug with a user that has edit permissions for the bug.

Actual Results:  
"Reassign bug to owner of selected component" appears as an option.


Expected Results:  
"Reassign bug to owner and QA contact of selected component" should appear instead.
(Reporter)

Comment 1

14 years ago
I tried the fix I gave, and it works, except an additional space is needed at
the front of the quoted string to prevent it from running into the preceding
text.  So it should be:

      <input type="radio" name="knob" value="reassignbycomponent">
      Reassign bug to owner
      [% " and QA contact" IF Param('useqacontact') %]
      of selected component

Comment 2

13 years ago
This bug was fixed for a very long time: July 2002, see the CVS log below! Your
version must be *very* old. Please upgrade!

1.14 - gerv%gerv.net - 2002-07-21 07:14
Fixing trivial but obvious bug where "and QA contact" was not displaying
correctly; noticed on b.m.o. No bug number.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.