does not sort sequentially when sorting by sender

RESOLVED INVALID

Status

SeaMonkey
MailNews: Message Display
--
major
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: mfc7706, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040219
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040219

After I upgraded to 1.7a, the mail date ordering does not happen properly.
Mozilla is sorting more on the basis of time, rather than date. 
Thus if I sort by sender, it will show sender Bob's messages out of sequence.

This bug is only applicable when sorting by sender

Reproducible: Always
Steps to Reproduce:
1.Sort by sender
2.Observe the lack of sequence of the mails for any one sender
3.

Actual Results:  
The same senders mails are out of sequence

Expected Results:  
sort it by sender and and also sort date/time wise

This is a major bug that has caused me to discontinue using Mozilla mail.

Comment 1

14 years ago
I don't know about Mozilla Mail but it works for me with Thunderbird.
Mozilla Thunderbird 0.5+ (20040319)

Comment 2

14 years ago
When one particular sort order (such as Sender) is chosen, the secondary 
criterion for sorting is "order received" (which is often, but not always, the 
same as date).  You can sort by Order Received directly to confirm this.

Bug 57898 is a request for multi-criterion sort; if that gets implemented, you 
could then sort on Sender and Date and get the results you want.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.