Install attempt produced message "** CRITICAL **: file eazel-theme-draw.c: line 885 (draw_box): assertion `width >= -1' failed."

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: daltman, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.5 StumbleUpon/1.63
Build Identifier: http://ftp.mozilla.org/pub/mozilla.org/mozilla/releases/mozilla1.7b/mozilla-i686-pc-linux-gnu-1.7b-installer.tar.gz

Trying to install Mozilla 1.7b from a download Wednesday night (3/24/04) on an
Intel PC running Linux-Mandrake 8.2 reproducably produces the message

"** CRITICAL **: file eazel-theme-draw.c: line 885 (draw_box): assertion `width
>= -1' failed."

When the installation apparently completes and the browser tries to start, the
following message appears at the command line:

"Gdk-ERROR **: BadWindow (invalid Window parameter)
	serial 1506 error_code 3 request_code 61 minor_code 0"

and then browser startup hangs. Otherwise, everything in the newly created
"mozilla" directory looks like a normal install.

The problem occurs with both the "Typical" and "Complete" installations.

The same Gdk error also appears if "./mozilla" is run from the mozilla directory
after the installation.

The same build installed with no problems on Windows 98 on the same machine.

Reproducible: Always
Steps to Reproduce:
1. Uncompress the installer download
2. In the directory mozilla-installer, type "./mozilla-installer"
3. Wait for the error message to appear ;-)

Actual Results:  
The message
"** CRITICAL **: file eazel-theme-draw.c: line 885 (draw_box): assertion `width
>= -1' failed.",
then the installer exited.

A few seconds later, when the browser tried to autostart, the error message
"Gdk-ERROR **: BadWindow (invalid Window parameter)
	serial 1506 error_code 3 request_code 61 minor_code 0"
appeared.

Expected Results:  
The browser should have started.

Comment 1

15 years ago
> "** CRITICAL **: file eazel-theme-draw.c: line 885 (draw_box): assertion `width
> >= -1' failed."

do you get this while the installer is downloading the components or while it's
installing (or both)?  you're using the eazel theme, right?  do you get the same
behavior with other themes?

when it's all done, do you have a working Mozilla installation?

Comment 2

15 years ago
==> Installer
Assignee: general → general
Component: Browser-General → Installer
QA Contact: general → bugzilla

Comment 3

15 years ago
@reporter

can you answer to Andrew Schultz questions? Else I will close this bug as works 
for me (cause there are known problems with the etzel theme, but that are not 
our bugs).

Updated

15 years ago
QA Contact: bugzilla → agracebush
Product: Browser → Seamonkey

Comment 4

14 years ago
no response.  resolving WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.