image panning/scrolling

RESOLVED WORKSFORME

Status

()

--
enhancement
RESOLVED WORKSFORME
15 years ago
6 years ago

People

(Reporter: davidmaxwaterman+bugzilla-daemon, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040315 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040315 Firefox/0.8.0+

Please consider implementing a feature to allow panning across an image which
larger than the window. Currently, you can pan using the scroll bars, but it
would be much nicer to be able to use the space bar along with the mouse - or
maybe there is an easier way.

Reproducible: Always
Steps to Reproduce:
1.view large image
2.try to pan/scroll
3.

Actual Results:  
awkward

Expected Results:  
easy

Updated

14 years ago
OS: MacOS X → All
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
Panning is definitly a lot easier than scrolling
->NEW

related to Bug 310278 (panning of whole pages)
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Bug 269899 has been marked as a duplicate of this bug. ***

Comment 4

13 years ago
I very much agree this is a problem.  Perhaps a middle mouse button could be
used to pan, or spacebar+left mouse, similarly to Photoshop.  Looking at 
NOAA weather maps, for example, is very painful without this feature.

Thanks a lot,
Jan
Assignee: bross2 → nobody
QA Contact: general
Spacebar and middle-click panning works for me as tested with Firefox 21 in OSX 10.8
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.