Crash when clicking on link on http://www.usatoday.com/sports/sfront.htm

VERIFIED DUPLICATE of bug 53317

Status

()

P3
critical
VERIFIED DUPLICATE of bug 53317
19 years ago
18 years ago

People

(Reporter: scottputterman, Assigned: pnunn)

Tracking

({crash, regression})

Trunk
PowerPC
All
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
When I go to http://www.usatoday.com/sports/sfront.htm and then click on scores
(in the left hand table of contents), I get the following crash:

0341e8b1()
nsFrameImageLoader::Notify(nsIImageRequest * 0x0333f4e0, nsIImage * 0x032c7af0,
nsImageNotification nsImageNotification_kPixmapUpdate, int 0, int 0, void *
0x0012fbe4) line 420
ns_observer_proc(void * 0x0333f380, long 4, void * 0x0012fc58, void *
0x0333f4e0) line 97
XP_NotifyObservers(OpaqueObserverList * 0x0333f410, long 4, void * 0x0012fc58)
line 259 + 28 bytes
il_pixmap_update_notify(il_container_struct * 0x0333f210) line 307 + 18 bytes
il_flush_image_data(il_container_struct * 0x0333f210) line 215 + 9 bytes
ImgDCallbk::ImgDCBFlushImage(ImgDCallbk * const 0x03410f10) line 162 + 12 bytes
il_gif_write(il_container_struct * 0x0333f210, const unsigned char * 0x022a8fe4,
long 0) line 1488
process_buffered_gif_input_data(gif_struct * 0x03326730) line 669 + 16 bytes
gif_delay_time_callback(void * 0x0333f210) line 713 + 9 bytes
timer_callback(nsITimer * 0x032d73c0, void * 0x032d53e0) line 71 + 12 bytes
TimerImpl::Fire(unsigned long 15275562) line 312 + 17 bytes
TimerImpl::ProcessTimeouts(unsigned long 15275562) line 191
FireTimeout(HWND__ * 0x00000000, unsigned int 275, unsigned int 14113, unsigned
long 15275562) line 105 + 9 bytes
USER32! 77e7185c()
nsAppShellService::Run(nsAppShellService * const 0x0108dca0) line 466
main1(int 1, char * * 0x01013100) line 622 + 32 bytes
main(int 1, char * * 0x01013100) line 710 + 13 bytes
mainCRTStartup() line 338 + 17 bytes
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M14
(Assignee)

Comment 1

19 years ago
Scott:
I'm not seeing this one with my local build.
I have a few bug fixes queued up to check in,
which may also fix this one.

Does this happen every time you click on 'scores'?
Does the crash happen when you click on any of the
other items on the left menu?

I won't close it until we get more info on the problem.
-P
(Reporter)

Comment 2

19 years ago
Yes it happens on Latest News as well as Sagarin Ratings.  It happens on both my
debug and release builds from this morning.  It happens every time.  If you want
to send me patches I could try them out.
(Reporter)

Comment 3

19 years ago
I tried this on someone else's machine and got the same crash.  I had to go to
scores and then hit back to go to the original page before it happened.  I'm
wondering if it's one of the ads on the top of the page that's causing it and I
keep getting that ad and you are not?
(Assignee)

Comment 4

19 years ago
I haven't yet seen the crash.
I'm hoping one of my fixes(checked in this afternoon)
took care of the bug, but I haven't backed out my
change to test the theory yet.
-p

Updated

19 years ago
Severity: normal → critical

Comment 5

19 years ago
Pam,

I can't reproduce this --- but I have seen quite a few irreproducible crashes in
nsFrameImageLoader in recent builds. Will let you know if they go away using
builds from 1.14.00 or later.
(Reporter)

Comment 6

19 years ago
Due to all of the bustage this morning, I haven't had a chance to play with
today's builds.  I will try it as soon as I have one with the most recent
changes to see if I can still reproduce it.  I'm on a different computer today,
but hopefully that won't make a difference.
(Assignee)

Comment 7

19 years ago
Scott:
How is this bug looking to you
with current builds?
-P
(Reporter)

Comment 8

19 years ago
It worked for me with this morning's build.  Marking WORKSFORME.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 9

19 years ago
Unable to reproduce on Mac OS or Win32 using builds from past 3 days, as well. 
Rubber-stamping as Verified/WORKSFORME.
Status: RESOLVED → VERIFIED

Comment 10

18 years ago
Doesn't work for me.

Reported crashes on 2000091308/win2000 (mine)
2000091212, 20000909 win2000.

Supposedly does NOT crash on today's build. Reopening bug and marking
as a regression, this bug keeps coming and going.

There's also at least 2 talkback reports from me about this.
Status: VERIFIED → REOPENED
Keywords: crash, nsbeta3, regression
Resolution: WORKSFORME → ---

Comment 11

18 years ago
dup of 52494


*** This bug has been marked as a duplicate of 52494 ***
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 12

18 years ago
Works for me under Linux, build 2000092721.

Comment 13

18 years ago
Reopening. WFM on Win98 and Linux, but crashes on Mac commercial branch 10/4 
build.
Status: RESOLVED → REOPENED
OS: Windows NT → Mac System 9.0
Hardware: PC → Macintosh
Resolution: DUPLICATE → ---
Target Milestone: M14 → M18
(Assignee)

Comment 14

18 years ago

*** This bug has been marked as a duplicate of 53317 ***
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 15

18 years ago
Worksforme on Mac, verified.
Status: RESOLVED → VERIFIED
OS: All
You need to log in before you can comment on or make changes to this bug.