{inc}Incremental table reflow doesn't like overflow: hidden children

RESOLVED DUPLICATE of bug 234593

Status

()

RESOLVED DUPLICATE of bug 234593
15 years ago
14 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

({qawanted})

Trunk
x86
All
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040125
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040125

There are pieces of the page that are displayed in other browsers but is not
displayed in mozilla. 

Reproducible: Always
Steps to Reproduce:
1.go to the url
2.
3.

Actual Results:  
broken page loads.  apologies for lack of description, the missing text is
listed in Expected Results

Expected Results:  
It should display the text below:


------------cut 'n' paste-------------


Welcome to the Global Growth Group, LLC.  


 


Our Mission:

At the Global Growth Group, our mission is to provide our clients with thorough
and accurate information on a timely basis. Those who are familiar with us know
we are genuinely committed to fulfilling this sincere commitment to quality service.

This commitment challenges us to: 
Set the highest standards of integrity for all of our work

Hire the most qualified people and provide quality training

Provide the highest quality research reports 


Our commitment to quality has resulted in hundreds of satisfied clients and more
than 25 years of success. Quality is not just something we talk about. It's
something that's evident in everything we do.


We recommend the ABCpdf .NET PDF generation component...

Comment 2

15 years ago
Created attachment 144908 [details]
empty javascript file

an empty file

Comment 3

15 years ago
Created attachment 144909 [details]
simplified test-case

this is a simplified test-case.
I can't understand why it fails just by referencing a javascript file in the
middle of the tables, even if it is an empty one.

Comment 4

15 years ago
Moving to Layout for better triaging.
Seen on wXP -> OS:All
Keywords: qawanted
OS: Linux → All

Comment 5

15 years ago
Really moving.
Assignee: general → nobody
Component: Browser-General → Layout
QA Contact: general → core.layout

Comment 6

15 years ago
The URL given, and 2nd attachment, load and render all the text here, as far as
I can tell. Seamonkey, build ID 2004032802.

The URL one, at least, stretches the left-hand-side to be 100% browser-width,
pushing the main content off the right. It all appears to be there, I just need
to scroll it horizontally.

Comment 7

15 years ago
James:
doesn't the testcase also show an horizontal scrollbar for you?

Comment 8

15 years ago
I does, yes. My point was that "missing stuff" is not a description of what's
happening.

This appears to be an incremental reflow problem. Seems not be updating the
first cell's size information when it finally continues after waiting for the
script. An interesting effect of this is that if you resize the window width
after the attchment has loaded completely, it seems to act as if the 100% width
of the cell initially is working as it's minimum allowed width.

Updating summary to reflect actual problem. Hopefully someone can work out where
this really belongs.

It appears the .clip { overflow: hidden; } CSS rule is required for this to
break, as is the width="100%" on both tables. I can't check what layout's doing,
unfortunately, as my debug build is crashing on startup. :(
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: does not display properly, missing stuff, displays in konqueror → Incremental table reflow doesn't like overflow: hidden children
Summary: Incremental table reflow doesn't like overflow: hidden children → {inc}Incremental table reflow doesn't like overflow: hidden children

Updated

14 years ago
Depends on: 234593

Comment 9

14 years ago
the issue is now fixed with the patch in bug 234593

*** This bug has been marked as a duplicate of 234593 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.