[PP] Plain text msg only - last url(s) is shown as link and not clickable

VERIFIED DUPLICATE of bug 22036

Status

MailNews Core
Backend
P3
normal
VERIFIED DUPLICATE of bug 22036
18 years ago
10 years ago

People

(Reporter: pmock, Assigned: rhp (gone))

Tracking

Trunk
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build Date & Platform Bug Found:
 MacOS commercial seamonkey build 2000-01-12-08-m13 installed on G3/400 OS 8.6

Overview Description:
 Viewing plain text mail messages sent from Communicator 4.7 or seamonkey, the
last one/two url does not show up as a hyperlink when viewed in seamonkey.  This
occurs only on Mac seamonkey.  Plain text messages sent from seamonkey view ok on
Communicator 4.7, linux seamonkey, and win32 seamonkey.

On the mac, seamonkey displays all the text completely.
 e.g. http://www.netscape.com
but it does not show with an underline and does not appear as a clickable link.
Nothing happens if you try to click on the link.

If I use 4.7 to view the page source of my messages, they look fine and display
fine on (seamonkey and 4.7) win32 and linux

* Reported by Kathy Brade (brade@netscape.com). She is seeing this problem
consistantly in her debug and optimized builds. It's very annoying.

Steps to Reproduce:
0) From Communicator 4.7 or mac seamonkey, send yourself a plain text mail
message using the plain text editor.  In my test message, I typed in five links
that were the same.  Example:
  http://www.netscape.com
  http://www.netscape.com
  http://www.netscape.com
  http://www.netscape.com
  http://www.netscape.com
1) Launch Mac commercial seamonkey
2) Open Messenger
3) Log into mail.
   It doesn't matter POP/IMAP
4) Select the mail message you sent
   The message displays.  Notice the last one/two links are not clickable and
don't display as a link.

Actual Results:
 The last one or two url do not display as links.  The last one or two url are
not clickable.
 Under IMAP, plain text message sent from 4.7 has two link not display as links.
Plain text message sent from seamonkey has only one link that does not display as
a link.
 Under local mail, plain text message sent from 4.7 has ONE link not display as
links. Plain text message sent from seamonkey has TWO link that does not display
as a link.  (Go figure ??? this happens)


Expected Results:
 All the url should display as link.  All links should be clickable.

Additional Builds and Platforms Tested On:
 This problem does not occur on win32 commercial seamonkey build 2000-01-12-09-
m13 and does not occur on linux commercial seamonkey build 2000-01-13-08-m13.
This problem does not occur on Mac/Win32/Linux Communicator 4.7 RTM.

Additional Information:
 It does not matter if you are viewing the message under IMAP or Local mail.
This problem does not occur on HTML mail messages sent from Communicator 5.0 or
seamonkey.

* I will attach a sample mail folder with 1 plain text message sent from
seamonkey and one sent from Communicator 4.7

Comment 1

18 years ago
Propably a DUP of bug #22306.
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 2

18 years ago
Already have this one.

- rhp

*** This bug has been marked as a duplicate of 22306 ***
(Reporter)

Updated

18 years ago
Status: RESOLVED → REOPENED
QA Contact: lchiang → pmock
(Reporter)

Updated

18 years ago
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
(Reporter)

Comment 3

18 years ago
I believe the bug number is incorrect.  It probably should be bug 22036 and not
bug 22306.

I'm re-openning this bug so I can resolve it against 22036 before verifying.
(Reporter)

Comment 4

18 years ago
*** This bug has been marked as a duplicate of 22036 ***
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

18 years ago
Verified as duplicate of bug 22036
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.