Closed Bug 238889 Opened 16 years ago Closed 16 years ago

Tooltip text misrender for ACRONYM and ABBR tags if TITLE attribute contains a newline.

Categories

(Firefox :: General, defect, trivial)

x86
Linux
defect
Not set
trivial

Tracking

()

RESOLVED DUPLICATE of bug 67127

People

(Reporter: cwright-fb, Assigned: bugzilla)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8

When an ACRONYM or ABBR tag's TITLE strings has a newline character (Unix flavor
at least), the tooltip attempts to display this character, and it shows up as a
black box.  The supplied URL demonstrates this with 4 text strings.  The first
two are 'normal' ACRONYM/ABBR tags with non-newline'd TITLE's, the second two
are the same but with a newline in the TITLE.  

Reproducible: Always
Steps to Reproduce:
1. visit URL
2. move mouse over first two texts (no problems)
3. move mouse over second two texts (ooo, pretty boxes :)

Actual Results:  
nothing catastrophic, just not visually pleasing.

Expected Results:  
Unless it's in W3C specs that All Characters Must Be Displayed, parsing out
general characters like that might be a bit easier on the eyes if it happens
randomly.  Pico is good at randomly wrapping strings, quoted or non, and I'm
sure other editors out there do the same (sadly).

This seems to be reproducable across several different character encodings,
including Western (ISO-8859-1), Japanese (Shift-JIS), and Unicode (UTF-8).  The
fonts used were standard Serif fonts (as far as I can tell).
This is on the most frequently duped bugs list.

*** This bug has been marked as a duplicate of 67127 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.