Closed Bug 238957 Opened 20 years ago Closed 20 years ago

15% Tp regression on redwood (gtk2 Firefox)

Categories

(Core :: Disability Access APIs, defect)

x86
Linux
defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: jruderman, Assigned: Louie.Zhao)

References

()

Details

(Keywords: perf, regression)

Attachments

(1 file)

Tinderbox graph:
http://axolotl.mozilla.org/graph/query.cgi?tbox=redwood&testname=pageload&autoscale=1&size=&units=&ltype=&points=&showpoint=2004%3A03%3A25%3A11%3A16%3A13%2C1069&avg=1&days=30

There were two checkins between the last fast build and the first slow build:

bug 235719 mozilla toplevel windows don't generate at-spi window: events (patch
includes gtk2-specific code)

bug 238468 NS_APPSTARTUPNOTIFIER_CONTRACTID should not live very long
Louie has already found the real cause, will provide a patch soon.
OS: Windows XP → Linux
Attached patch patch v1Splinter Review
Without checking "sAccessibilityEnabled", Accessibility feature will be always
enabled in spite of env var "GNOME_ACCESSIBILITY". This is the reason of the
regression. The patch check "sAccessibilityEnabled" first like
http://lxr.mozilla.org/seamonkey/source/widget/src/gtk2/nsWindow.cpp#2306.
Attachment #145071 - Flags: review?(kyle.yuan)
Attachment #145071 - Flags: superreview?(Henry.Jia)
Attachment #145071 - Flags: approval1.7?
Comment on attachment 145071 [details] [diff] [review]
patch v1

r=kyle.yuan

Henry is on vacation, over to bryner.
Attachment #145071 - Flags: superreview?(bryner)
Attachment #145071 - Flags: superreview?(Henry.Jia)
Attachment #145071 - Flags: review?(kyle.yuan)
Attachment #145071 - Flags: review+
Attachment #145071 - Flags: superreview?(bryner) → superreview+
Comment on attachment 145071 [details] [diff] [review]
patch v1

a=chofmann for 1.7
Attachment #145071 - Flags: approval1.7? → approval1.7+
Louie checked in the patch 16 hours ago.  Tp is back to normal on redwood :)
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: