Firefox crashes,if we open "New Bookmark" with "Alt+B",after selecting and cutting all the existing bookmark in "Manage Bookmarks".

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
critical
RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: Mridula, Assigned: Pierre Chanial)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

62.50 KB, application/octet-stream
Details
(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

If we select all the existing bookmark in "Manage Bookmarks", then cut the
selected bookmark using "Ctrl+X" and then try to open "New Bookmark" using
"Alt+B" or open "New Folder" using "Alt+F" ,Firefox crashes, but, if we try to
open "New Separator" using "Alt+S" it doesnot crash.

Reproducible: Always
Steps to Reproduce:
1) Select Bookmarks->Manage Bookmarks
2) Do "Ctrl+A" to select all the existing bookmarks
3) Do "Ctrl+x" to Cut the selected bookmarks
4) Open the "New Bookmark" using "Alt+B" or try to open "New Folder" using "Alt+F"

Actual Results:  
Firefox crashes.

Expected Results:  
The "New Bookmark" and "New Folder" should have worked like "New Separator".
Works for me using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b)
Gecko/20040324 Firefox/0.8.0+

Please try installing into a new directory and creating a new profile, using the
MozillaFirebird.exe -p switch, and report your results here.  Please make sure
to test using nightly builds and not milestone builds before reporting bugs.

Updated

14 years ago
Keywords: crash

Comment 2

14 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8
> 
> If we select all the existing bookmark in "Manage Bookmarks", then cut the
> selected bookmark using "Ctrl+X" and then try to open "New Bookmark" using
> "Alt+B" or open "New Folder" using "Alt+F" ,Firefox crashes, but, if we try to
> open "New Separator" using "Alt+S" it doesnot crash.
> 
> Reproducible: Always
> Steps to Reproduce:
> 1) Select Bookmarks->Manage Bookmarks
> 2) Do "Ctrl+A" to select all the existing bookmarks
> 3) Do "Ctrl+x" to Cut the selected bookmarks
> 4) Open the "New Bookmark" using "Alt+B" or try to open "New Folder" using "Alt+F"
> 
> Actual Results:  
> Firefox crashes.
> 
> Expected Results:  
> The "New Bookmark" and "New Folder" should have worked like "New Separator".

Confirmed.

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040330
Firefox/0.8.0+
Microsoft Windows 2000 Pro 5.00.2195 SP4
(Reporter)

Comment 3

14 years ago
Created attachment 145175 [details]
Crash Screen Shot
(Reporter)

Comment 4

14 years ago
User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) 
Gecko/20040330 Firefox/0.8.0+

Replicated the same bug in the nightly build and I have attached a screen shot 
of it.

Comment 5

14 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040404
Firefox/0.8.0+

I got stuck at step 3, as when all bookmarks (including folders) were
selected, I couldn't perform the cut operation, and I got this message

ONSELECTION CHANGED
************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "Component returned failure code: 0x80070057
(NS_ERROR_ILLEGAL_VALUE) [nsIXULTreeBuilder.getResourceAtIndex]"  nsresult:
"0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame ::
chrome://browser/content/bookmarks/bookmarksTree.xml :: getRowResource :: line
259"  data: no]
************************************************************

If I tried with only bookmarks selected, then I could cut, create a new
bookmark and paste back my actual bookmarks without a crash.

Ben
WFM
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040604
Firefox/0.8.0+ (stipe)

Comment 7

14 years ago
WFM - Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040607
Firefox/0.8.0+
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040607
Firefox/0.8.0+
I cannot reproduce this bug in either the latest branch or trunk of Firefox, I
did try it on the 0.8 milestone and it crashed so sometime between the 0.8
milestone release this got fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.