[PP]CSS support not working at HotBot site

VERIFIED FIXED in M2

Status

()

Core
HTML: Parser
P2
major
VERIFIED FIXED
19 years ago
11 years ago

People

(Reporter: Chris Petersen, Assigned: rickg)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Version: Viewer.exe
Build: Thurs Jan 14th
Platform: Windows NT
Other Platforms: Windows 98, Win 95.
Expected Results:
The HotBot site to be use CSS to layout images correctly.
What I got:
The HotBot logo and text are displayed flush left and appear on top of each
other.
Steps to Reproduce:
1) Go to www.hotbot.com
2) Notice the way the layout is displayed. The Hotbot logo and text are placed
flush left.

Updated

19 years ago
Assignee: peterl → troy

Comment 1

19 years ago
Looks like absolute positioning problems?
BTW: view source is also quite broken on this page. Please transfer to rickg
when done for that.

Updated

19 years ago
Assignee: troy → rickg
Component: Style System → Parser

Comment 2

19 years ago
There are at least two parser problems that are causing things to get screwed
up.

The first problem is that DIV tags aren't nesting like they should. Here's a
small subset of the HTML that demonstrates that problem. The second problem can
be seen if you remove the FORM tag enclosing the SELECT element. That causes all
of the various OPTION text to just become text inside of the second DIV

Here's the HTML:

<html>
<head><title>HotBot</title>

<style>
#text2 {font-family:Verdana,Arial,Geneva; font-size:12px}
#searchFont {font-family:courier,new-courier,monospace; font-size:11px}

.searchContent{
top:59px;
left:0;
width:202px;
position:absolute;
border-color:#FF0000 ; border-right-style:solid; border-right-width:3px;
background-color:#99FF33;
layer-background-color:#99FF33;
z-index:10;
padding-left:6px;
float:left;
}
.redBox1{
font-size:14px;
color:#FFFFFF;
border:1px none red; layer-background-color:#FF0000; background-color:#FF0000;
width:175px;
padding-bottom:2px;
}
</style>
</head>
<body text=#000000 link=#3333CC vlink=#660099 bgcolor=#FFFFFF>
<div CLASS="searchContent" ID="searchFont">
<div ID="text2">
<form>
<SELECT name="SM" >
<OPTION value="MC" selected>all the words
<OPTION value="SC">any of the words
<OPTION value="phrase">exact phrase
<OPTION value="title">the page title
<OPTION value="name">the person
<OPTION value="url">links to this URL
<OPTION value="B">Boolean phrase
</SELECT>
</form>
</div>
</div>

</body></html>
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 3

19 years ago
This is completed fixed yet, but it's much better.
(Assignee)

Updated

19 years ago
Assignee: rickg → peterl
Status: ASSIGNED → NEW
(Assignee)

Comment 4

19 years ago
Peter, I think this is yours now. CSS appears to be coming through.
Also, can you comment on what you saw with view-source? It looks pretty good to
me.
(Assignee)

Updated

19 years ago
Component: Parser → Style System
(Assignee)

Comment 5

19 years ago
Peter, I think this is yours now. CSS appears to be coming through.
Also, can you comment on what you saw with view-source? It looks pretty good to
me.

Updated

19 years ago
Assignee: peterl → troy

Comment 6

19 years ago
Still some positioning problems. I think the style data is OK.
Still problems with view source. I sent seperate data to rickg on that.

Updated

19 years ago
Assignee: troy → rickg
Component: Style System → Parser

Comment 7

19 years ago
There's still at least one problem with the parser. And that INPUT element in
the upper-left corner looks like a parser problem as well...

Case #1:
<html>
<head><style>
.redBox2{
color:#FFFFFF;
border: 1px none red; layer-background-color:#FF0000; background-color:#FF0000;
padding:2px;
padding-right:3px;
width:10px;
}
</style></head>
<body>
<div CLASS="redBox2" ID="text2">
<input type="SUBMIT" name="submit" value="SEARCH" ID="searchFont">
</div>
</body>
</html>
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 8

19 years ago
Fixed by improvements to new DTD system; also fixed one in comment parsing.

Comment 9

19 years ago
petersen, could you please Verify this today?  Thanks!
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 10

19 years ago
This problem is fixed in the Thurs Jan 21 build.

Comment 11

19 years ago
Inserting Milestone info.
You need to log in before you can comment on or make changes to this bug.