Closed Bug 239229 Opened 19 years ago Closed 19 years ago

Dynamically inserting form inputs into table cells results in incorrect ordering of values in form

Categories

(Core :: Layout: Form Controls, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 204784

People

(Reporter: asefkow, Unassigned)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316

I have a table with IDs on the TDs.  When the page loads, I am running
JavaScript that replaces the table cells' INNERHTML with INPUTs.  But when the
form is submitted, the values are not ordered correctly -- not according to the
sequence that they appear in the HTML.  This does NOT reproduce with Internet
Explorer or Opera -- only Netscape 7.1 and Mozilla (tested 1.7).

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.geocities.com/asefkow/MozillaBug.html
2. Change the FIRST dropdown list from Hidden to Shown


Actual Results:  
You will see an alert that shows the values of two other input elements, ones
that were dynamically created.  The values shown on Mozilla are ",1" indicating
that teh SECOND dropdown list was chosen, which is not the case.

Expected Results:  
On IE and Opera, you see "1,".  This indicates that the FIRST dropdown list was
chosen, which is true.
Compare results with IE and Opera.

*** This bug has been marked as a duplicate of 204784 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.