div width is modified by padding

VERIFIED INVALID

Status

()

Core
Layout
--
major
VERIFIED INVALID
14 years ago
13 years ago

People

(Reporter: morpheus, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

When a width is specified for a <div> and padding is added, the padding
increases the width of the <div>.

Reproducible: Always
Steps to Reproduce:
See attachment.
(Reporter)

Comment 1

14 years ago
Created attachment 145164 [details]
Testcase exhibiting bug
It's supposed to.

See also http://tantek.com/CSS/Examples/boxmodelhack.html
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Yes, this is how W3C defines width/height and padding.

Verified invalid.
Status: RESOLVED → VERIFIED

Comment 4

13 years ago
*** Bug 306366 has been marked as a duplicate of this bug. ***

Comment 5

13 years ago
*** Bug 323282 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.