Sorting of search results is goofy

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Jeff Jewell, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.6.1 StumbleUpon/1.87
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.6.1 StumbleUpon/1.87

Clicking on column headings to sort gives intermittently bad results.  I've not
figured out a clear pattern.  Example:  Click on the date header and results are
sorted, but not into the correct order.  I've had similar problems sorting on
Priority, Sender, Subject, etc.

Reproducible: Always
Steps to Reproduce:
1.  Do a search.
2.  Click on the date column to initiate a sort.
3.  Check results.
Actual Results:  
It seems that the sort was done on the sender field.

Expected Results:  
It should short by date.
(Reporter)

Comment 1

14 years ago
I'm not sure why there is not (or why I can't find) a good place to indicate
what build of software I'm using to get this bug, but it's 0.5 20040120 -- As an
aside, why is it that it seems to be very common to have "about" windows that do
NOT allow you to copy the information presented?  How ridiculous is that.  Why
make someone retype it when a copy/paste would be less error prone?
(Assignee)

Comment 2

14 years ago
copy and pasting the build id from the about dialog works great for me.
(Reporter)

Comment 3

14 years ago
(In reply to comment #2)
> copy and pasting the build id from the about dialog works great for me.

Strange--works for me now, too.  It didn't work before.  I swear.  It didn't
work.  Note, however, I'm testing under Win2K, so only the devil knows for sure
whether it's a software bug or an OS bug on that issue.  I see that behavior
more often on Micro$oft stuff.  I'm glad to see that it was only a bad dream
this time:  Mozilla Thunderbird 0.5a (20040120)  [pasted]

Unfortunately, the main issue of sorting search results is still there.  Maybe
I'm still dreaming...ouch--no, I just verified it.  I'm awake.  Sorting search
results still looks goofy to me.

Comment 4

14 years ago
Jeff, please try to this on a recent build, 0.8 at least, and see if you still
get these results. I can't reproduce this.
(Reporter)

Comment 5

14 years ago
(In reply to comment #4)
> Jeff, please try to this on a recent build, 0.8 at least, and see if you still
> get these results. I can't reproduce this.

I guess that I must reluctantly ask that this be closed or put into some kind of
dormant state.  I can't get it to fail now myself--and I'm talking about the
original 0.6 build that I was using, let alone something newer like 0.8 as you
suggested.  I do know for sure that it was failing, because I banged my head
against it for quite some time in the past.  I suspect that this may rear its
head again in the future as an intermittent (maybe low memory related?) problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.