Last Comment Bug 239307 - Remove "Send Link..." from context menus
: Remove "Send Link..." from context menus
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Menus (show other bugs)
: unspecified
: All All
: -- enhancement with 10 votes (vote)
: Firefox 16
Assigned To: Jared Wein [:jaws] (please needinfo? me)
:
: Jared Wein [:jaws] (please needinfo? me)
Mentors:
Depends on: 786185
Blocks: 770419
  Show dependency treegraph
 
Reported: 2004-03-31 15:51 PST by Steven Garrity [:sgarrity]
Modified: 2013-09-09 09:38 PDT (History)
27 users (show)
jaws: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch for bug (8.23 KB, patch)
2012-06-12 02:03 PDT, Jared Wein [:jaws] (please needinfo? me)
fryn: review-
Details | Diff | Splinter Review
Patch for bug v2 (13.21 KB, patch)
2012-06-29 16:48 PDT, Jared Wein [:jaws] (please needinfo? me)
fryn: review+
shorlander: ui‑review+
Details | Diff | Splinter Review

Description Steven Garrity [:sgarrity] 2004-03-31 15:51:42 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040321 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040321 Firefox/0.8.0+

The "Send Link..." and "Send Image..." menu items from the link and image
context menus, respectively.

The sending an image or link can also be achieved by following the link or
clicking "View Image..." and then using the File -> Send Page... menu item.

Related discussion in the MozillaZine Forums:
http://forums.mozillazine.org/viewtopic.php?t=65126

Reproducible: Always
Steps to Reproduce:
1. Right click on an image or a link
2. Notice the "Send Image..." or "Send Link..." menu items
3. Take a deep breath
Comment 1 Bill Mason 2004-03-31 21:20:21 PST
Unless you are the developer working on a bug (in which case this should be
assigned to you), please do not assign a bug or set a milestone.  Those are for
the developers.
Comment 2 Steven Garrity [:sgarrity] 2004-04-01 07:43:21 PST
I guess I should have mentioned in a comment - Ben Goodger asked me to assign it
to 1.0beta.
Comment 3 Mike Connor [:mconnor] 2004-04-01 13:05:55 PST
This was a fairly common RFE before it was fixed.  Relying on File->Send Page 
makes people go farther from where they are focused and its not an obvious one 
if its an image.

Is the extra context menu entry so detrimental as to justify the extra steps 
involved?  You're talking about reducing usability in a given situation without 
providing the "win" in terms of how this helps the user in exchange.
Comment 4 Steven Garrity [:sgarrity] 2004-04-01 13:34:19 PST
Fair points Mike. The "win" is that the more frequent tasks used in the image
and link context menus are easier to get at with simpler menus.
Comment 5 Mike Connor [:mconnor] 2004-04-01 19:46:25 PST
I think we would be better served to focus on optimizing the order of the items
in the context menu rather than just killing them.  Copy Link Location should be
higher than Send Link is in the menu, but on just a link, we have a grand total
of seven entries.  If we're going to remove something for the sake of more
compact menus, why not Properties? (though in the case of images, its slightly
more useful)

In most cases, a larger context menu only affects usability if the useful
entries are at the bottom instead of the top.  I'll agree that some tweaking is
in order, but that's sort of separate.
Comment 6 Aaron Kaluszka 2004-07-20 06:53:59 PDT
This should be two separate bugs because a lot of people find Send Link useful,
but that may not be the case with Send Image.
Comment 7 Steven Garrity [:sgarrity] 2004-07-20 07:29:53 PDT
I've split off the request to move the "Send Image..." into bug #252277
Comment 8 Emil Ivanov 2007-09-11 15:32:10 PDT
I dont have mail client installed because i use webmail. And these "send" options are not working for me. I think they should be removed because they only fill the menus with useless space when there is no mail client installed.
Comment 9 Jared Wein [:jaws] (please needinfo? me) 2012-06-12 02:03:10 PDT
Created attachment 632170 [details] [diff] [review]
Patch for bug

This patch removes the "Send Link..." menuitem from the context menus.

It leaves the ability still in the Firefox app menu as well as the File menu. I specifically chose to leave it in the app menu and File menu since the new Australis customization palette will probably include this ability but keep it off of the initial menu by default.

Requesting ux-review to make sure that this is something that we want to do. It removes visual noise from our context menu and is likely a very low used feature.
Comment 10 Frank Yan (:fryn) 2012-06-29 15:24:02 PDT
Comment on attachment 632170 [details] [diff] [review]
Patch for bug

As suggested in the description, let's remove "Send Image" and "Send Video" in the same patch/bug.

Here's a helpful MXR search:
https://mxr.mozilla.org/mozilla-central/search?string=context-send
Comment 11 Frank Yan (:fryn) 2012-06-29 15:53:20 PDT
(In reply to Frank Yan (:fryn) from comment #10)
> As suggested in the description, let's remove "Send Image" and "Send Video"
> in the same patch/bug.

I found bug 252277 for that.

Instances of context-sendpage need to be removed from test_contextmenu.html
Comment 12 Jared Wein [:jaws] (please needinfo? me) 2012-06-29 16:48:06 PDT
Created attachment 638053 [details] [diff] [review]
Patch for bug v2

Thanks for catching that. I made the requested change and ran the mochitest locally with success.

Here's the usage statistics from gregglind for "Send Link As..." on the context menu for ui-review:

item      %people_used %mean_among_users %median %top5pct
sendimage 3.34         1.93              1       3
sendlink  0.89         1.4               1       4
sendpage  0.89         2.93              1       31

To interpret:
"Among Test Pilot Users (a technologically) sophisticated audience,
all three features are used, rarely. "Sendimage" is the most common
and has the most even distribution. Sendpage seems to be very heavily used,
but only by a tiny subset of users."
Comment 13 Jared Wein [:jaws] (please needinfo? me) 2012-07-03 14:03:16 PDT
Pushed to inbound:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6583faced02a
Comment 14 Ryan VanderMeulen [:RyanVM] 2012-07-04 06:38:51 PDT
https://hg.mozilla.org/mozilla-central/rev/6583faced02a
Comment 15 Gary King 2012-07-05 11:46:45 PDT
So for me to now send a link I have to :
 
1. Right Click on a link
2. Open up the menu bar
3. Click on File
4. Open email link
5. then send link.

Prior to this "Fix" all I had to do was RC and send link.

Is the mission of Mozilla to slow down the user's browsing experience or just to drive more users to Chrome. This fix is really insane.
Comment 16 Virtual_ManPL [:Virtual] - (ni? me) 2012-07-06 01:32:10 PDT
1. Right click on the link
2. "Copy Link Location"
3. "Paste" it where you want in your email etc.

Faster and menu is now clearer without too many not widely used options
Comment 17 Mardeg 2012-07-12 07:14:42 PDT
http://tinyurl.com/76gq9yw has a bookmarklet for emailing selected text from a page, it includes the page title in the subject line and page address in the body of the email before the selected text.
Comment 18 Peter Lairo 2012-08-14 14:20:49 PDT
I'd like to mention that "Send link" is the ONLY feature I ever use in the page's context menu, and it's the way I prefer to send a link via e-mail (Thunderbird)! So, for me, this "fix" is actually a breakage.
Comment 19 Sergey 2012-08-28 01:54:11 PDT
God plz do something bad to idiots who removed "send link" & "send page" from context menu.
Its absolutely irrational to break users UI experience.
Feature by feature Firefox loses all its own :(
Comment 20 f.smulders 2012-08-30 23:52:28 PDT
Damn! Who thought of this? Really bugs me.

As mentioned before, "Send link" was the only feature I used in the right click menu.

Please put it back, or at least add it as an option in about:config.
Comment 21 f.smulders 2012-08-30 23:57:05 PDT
(In reply to Virtual_ManPL from comment #16)
> 1. Right click on the link
> 2. "Copy Link Location"
> 3. "Paste" it where you want in your email etc.
> 
> Faster and menu is now clearer without too many not widely used options

How is that faster than: 
1. Right click
2. Send link

?
Comment 22 Bruce Momjian 2012-10-10 05:59:23 PDT
Another thing that Email/Send Link does is to set the email subject to match the web page title.  This is quite helpful, and another reason you still want Email Link functionality in the browser, rather than copying the link into an email.  Also, Ubuntu Classic doesn't display the Firefox appmenu.
Comment 23 Browsing User 2012-10-10 11:15:31 PDT
If you are unsatisfied with this new "feature" - as I am - then try this:
Email This! :: Add-ons for Firefox
https://addons.mozilla.org/en-us/firefox/addon/email-this/
Comment 24 Mark Sicignano 2012-10-12 08:08:04 PDT
Send link and Send image are my most used commands on the context menu. WTH. Bring them back.

This was a feature. Not a bug.  Why was it marked as a bug? Because somebody didn't like the feature? Grrr!
Comment 25 astro46 2012-10-14 21:52:20 PDT
send link was the only thing i used in rt click menu. this change sounds more like someone's power trip than anything else. On another board I am reading about people installing older versions of ff rather than deal with the continual "improvements". so, drive people to chrome or to older less secure versions. sounds good! 

If you are so concerned about the number of items in right click, rather than decide for them what users should want (hello microsoft?), better provide option to pick what will appear in context menus = simpler menus and more functionality at same time.
Comment 26 billrm 2012-10-15 11:08:36 PDT
This like when IE 'improves' things. New version = lose features or move them or hide them.

Maybe we can get Dolphin to build a desktop version. I already switched my Android phone to Dolphin because it was faster.
Comment 27 billrm 2012-10-15 11:15:20 PDT
(In reply to billrm from comment #26)
> This like when IE 'improves' things. New version = lose features or move
> them or hide them.
> 
> Maybe we can get Dolphin to build a desktop version. I already switched my
> Android phone to Dolphin because it was faster.

Just noticed this in comment #12:
 "Among Test Pilot Users (a technologically) sophisticated audience, all three features are used,...'

So to anyone else complaining here (like me), we're not 'sophisticated' users - so we stupid users should just go away. 

Must be time for me to go find a less sophisticated browser.
Comment 28 billrm 2012-10-15 11:17:27 PDT
(In reply to billrm from comment #27)
> (In reply to billrm from comment #26)
> > This like when IE 'improves' things. New version = lose features or move
> > them or hide them.
> > 
> > Maybe we can get Dolphin to build a desktop version. I already switched my
> > Android phone to Dolphin because it was faster.
> 
> Just noticed this in comment #12:
>  "Among Test Pilot Users (a technologically) sophisticated audience, all
> three features are used,...'
> 
> So to anyone else complaining here (like me), we're not 'sophisticated'
> users - so we stupid users should just go away. 
> 
> Must be time for me to go find a less sophisticated browser.

That should be:

 'Among Test Pilot Users (a technologically) sophisticated audience, all
three features are used rarely...'
Comment 29 Craig 2012-10-15 12:49:24 PDT
I really don't intend this to be a flame, rather a useful and helpful comment intended to drive firefox in a more productive direction.     I am just... unable to express exactly how bad of an idea it was to remove send link from the right click context menu of firefox.    

Looking at the bug report, it seems that this was an effort to remove unused clutter from the context menu.    The most used item on the context menu was the send link.      If you wanted to remove clutter, the back, forward, reload items could go without any hesitation.    I don't believe that I've ever seen anyone use those - and, they do exactly what the back, forward, and reload buttons on the main screen do.   The send link, send image, and other send context choices were truly useful!

I don't believe that I'm expressing any exaggerated frustration by saying that this was a truly bad idea on the order of the "new coke" fiasco.   

Please... put the menu items back and stop fiddling with the context menu!
Comment 30 chrialex 2012-10-15 23:13:23 PDT
(In reply to billrm from comment #28)

> That should be:
> 
>  'Among Test Pilot Users (a technologically) sophisticated audience, all
> three features are used rarely...'

To be fair:

""
Here's the usage statistics from gregglind for "Send Link As..." on the context menu for ui-review:

item      %people_used %mean_among_users %median %top5pct
sendimage 3.34         1.93              1       3
sendlink  0.89         1.4               1       4
sendpage  0.89         2.93              1       31

To interpret:
"Among Test Pilot Users (a technologically) sophisticated audience,
all three features are used, rarely. "Sendimage" is the most common
and has the most even distribution. Sendpage seems to be very heavily used,
but only by a tiny subset of users."
""

I have had 7 people ask me the last couple of days what happened to it, as they used that a LOT, as did I.  While browsing, I commonly come across news articles, pictures, or other things that I like to share with my wife and family/friends.  Like Craig said above, if clutter was wanted to be removed, adding an option to customize the context menu, or just getting rid of the navigation links in there would have made more sense.

Mike Conner said in Comment 3 that "Relying on File->Send Page 
makes people go farther from where they are focused and its not an obvious one 
if its an image."

I would like to see an updated chart of usage of this feature, compared to that in Comment 12, that has more detail, such as total numbers that those percentages represent.

If nothing else, please allow us non-Test Pilot, non-technologically sophisticated users that actually DO know what we are doing and have been in the IT field for years, add this back via about:config.

Thank you and have a good day.
Comment 31 john 2012-10-18 00:42:50 PDT
This was NOT a bug.  It is a oft-used feature for many people.  The bug is that people use Webmail systems instead of Fast, Feature filled Email clients and webmail systems are very slow to provide mailto link support.

I agree, let us turn it off or back on in about:config.  Along with Tabs on Top and Related New Tab after current, I'll be reversing that setting on every Firefox install.
Comment 32 Virtual_ManPL [:Virtual] - (ni? me) 2012-10-18 05:04:49 PDT
This feature was used by less than 1% of users, that's why it was removed. Even Chrome or Opera don't have this feature. So stop whining and use addon if you want this feature back:
(In reply to Browsing User from comment #23)
> Email This! :: Add-ons for Firefox
> https://addons.mozilla.org/en-us/firefox/addon/email-this/
Comment 33 f.smulders 2012-10-18 06:34:22 PDT
(In reply to Virtual_ManPL [:Virtual] from comment #32)
> This feature was used by less than 1% of users, that's why it was removed.
> Even Chrome or Opera don't have this feature. So stop whining and use addon
> if you want this feature back:

There are 125 million people using Firefox (according to http://howmanyarethere.net/how-many-people-are-using-firefox-all-over-the-world/). Less than 1% of that is still more than 1 million people using a feature. That is a lot!!
Comment 34 kobimaru 2012-10-18 09:11:11 PDT
I am very disheartened by this change to a user interface without at least asking for some additional feedback.  I have to tell you FireFox developers - bad move to remove this function.  I, and many others that continue to trumpet Firefox as browser of choice, used this context menu option religiously.  I think you should put it back on the menu.
Comment 35 Craig 2012-10-18 10:07:38 PDT
Virtual man:

The fact that Chrome, Opera, and IE don't have this feature is not a reason to remove it - indeed, it's the best reason to keep it.     If I want chrome, I'll download it and use it instead of Firefox.   Little bits of functionallity, like this context menu email function makes Firefox stand apart.   It makes Firefox worth having when compared to other browsers.    

By the way, if you think that this is whining, then you clearly don't understand the word.   This is an outpouring of concern from your support base.   We are the people who use, support, and even evangelize Firefox.     We are the people who tell the developers what's good and bad in the product - not a pilot group!   Pilot groups are used to try to get a feel for what the end user wants.   We ARE the end users and we're telling you, clearly and respectfully, what we want.  Ignoring this kind if feedback in favor of a pilot study would be insane!

Don't try to be Chrome.   Don't try to be Opera.   Don't try to be IE.   Try to be a better Firefox, distinct from other browsers.   Embrace the things that make Firefox unique - that's why we use Firefox in the first place. And, why we were using Netscape Communicator, Netscape Browser, and Mozilla in the past.   This is one of those unique things that makes Firefox a really cool browser!
Comment 36 hamiglorr 2012-10-18 13:43:02 PDT
(In reply to kobimaru from comment #34)
> I am very disheartened by this change to a user interface without at least
> asking for some additional feedback.  I have to tell you FireFox developers
> - bad move to remove this function.  I, and many others that continue to
> trumpet Firefox as browser of choice, used this context menu option
> religiously.  I think you should put it back on the menu.

I agree completely!
Comment 37 hamiglorr 2012-10-18 13:44:32 PDT
(In reply to Craig from comment #35)
> Virtual man:
> 
> The fact that Chrome, Opera, and IE don't have this feature is not a reason
> to remove it - indeed, it's the best reason to keep it.     If I want
> chrome, I'll download it and use it instead of Firefox.   Little bits of
> functionallity, like this context menu email function makes Firefox stand
> apart.   It makes Firefox worth having when compared to other browsers.    
> 
> By the way, if you think that this is whining, then you clearly don't
> understand the word.   This is an outpouring of concern from your support
> base.   We are the people who use, support, and even evangelize Firefox.    
> We are the people who tell the developers what's good and bad in the product
> - not a pilot group!   Pilot groups are used to try to get a feel for what
> the end user wants.   We ARE the end users and we're telling you, clearly
> and respectfully, what we want.  Ignoring this kind if feedback in favor of
> a pilot study would be insane!
> 
> Don't try to be Chrome.   Don't try to be Opera.   Don't try to be IE.   Try
> to be a better Firefox, distinct from other browsers.   Embrace the things
> that make Firefox unique - that's why we use Firefox in the first place.
> And, why we were using Netscape Communicator, Netscape Browser, and Mozilla
> in the past.   This is one of those unique things that makes Firefox a
> really cool browser!

Right on!
Comment 38 astro46 2012-10-18 14:42:32 PDT
(In reply to hamiglorr from comment #37)
> (In reply to Craig from comment #35)
> > Virtual man:
> > 
> > The fact that Chrome, Opera, and IE don't have this feature is not a reason
> > to remove it - indeed, it's the best reason to keep it.     If I want
> > chrome, I'll download it and use it instead of Firefox.   Little bits of
> > functionallity, like this context menu email function makes Firefox stand
> > apart.   It makes Firefox worth having when compared to other browsers.    
> > 
> > By the way, if you think that this is whining, then you clearly don't
> > understand the word.   This is an outpouring of concern from your support
> > base.   We are the people who use, support, and even evangelize Firefox.    
> > We are the people who tell the developers what's good and bad in the product
> > - not a pilot group!   Pilot groups are used to try to get a feel for what
> > the end user wants.   We ARE the end users and we're telling you, clearly
> > and respectfully, what we want.  Ignoring this kind if feedback in favor of
> > a pilot study would be insane!
> > 
> > Don't try to be Chrome.   Don't try to be Opera.   Don't try to be IE.   Try
> > to be a better Firefox, distinct from other browsers.   Embrace the things
> > that make Firefox unique - that's why we use Firefox in the first place.
> > And, why we were using Netscape Communicator, Netscape Browser, and Mozilla
> > in the past.   This is one of those unique things that makes Firefox a
> > really cool browser!
> 
> Right on!

i agree also.
as i mentioned before:  users would be more impressed by an option allowing users to determine what they see on menus, rather than a microsoft like approach where the developers decide what is good for the users.
Comment 39 Mark Jones 2012-10-20 09:15:43 PDT
TL;DR - Don't remove features that have existed in Firefox for a long time without providing a simple, quick way to get it back e.g. a user setting in about:config otherwise you will annoy a lot of people.

I am a user since the 0.x days. This is the first time Firefox developers have severely **** me off with a change. I have been broadly in support of nearly every move they have made, even those that others have been very critical of. I want to emphasise that I am fairly active around Firefox and this is the first time I have heard that this was going to be removed. I was not consulted about this or given the option to provide my feedback.

Who exactly was consulted about this and how?

If a feature is there and has been there for years you can bet people are using it and will have become very used to it being there. You DO NOT just remove things like that without providing a way to put it back. There should at least be a user setting in about:config to return it for those who are used to it and use it a lot.

The app/file menu link does not replicate this feature completely.

Comment #8 nobody really cares whether one person has a mail client installed and use web mail because there are people who do use a mail client (Mozilla Thunderbird - hello?) and don't use webmail. One set of users' needs do not override another.

Comment #12: What use is a test among technologically sophisticated users? Are they the bulk of Firefox users? No. Firefox should be aiming for the average user (who very likely will sends links to their friends by email.)

Whatever tool created the stat that Firefox users don't use the send link function I suspect was wrong or slanted in some way. Perhaps if the feature was advertised more, more people would have used it? It's just the sort of thing that if you posted it on the Firefox Facebook fan page as a productivity feature people would have said "Hey, this is a really great feature that saves me a lot of time!". Perhaps that was what was needed?

I do not want to install another addon to get this functionality back. I already have many addons and given the problems addons have caused in the past with memory (albeit now much less of a problem) siphoning out long-time  functionality into addons is not a great move.

All of these addons I use have added over a dozen extra items to the context menu so removing this one item does nothing at all to help me.

I posted to Mozilla developers in some forum (don't remember where) using Firefox 2.0 that they need to come up with a sensible way of segregating addon menus away from the native menus and this still hasn't been done. This would have been a far more sensible way to deal with menu clutter than completely removing well-established and used features.

Firefox is losing users by the thousands and if you don't adopt a better way of dealing with issues that don't run roughshod over users' opinions and feelings it will get worse.
Comment 40 Paul Menchini 2012-10-20 09:24:14 PDT
I (used to) use this feature all the time.  In fact, I don't use Chrome more in part because of the lack of this feature.  Surely it could be a user-controlled option, or could be controlled by the presence or absence of an MUA.

Please reconsider.
Comment 41 Bruce Momjian 2012-10-20 10:43:35 PDT
One thing I think would improve usability and which is easy to customize, would be to allow an "email link" icon on the toolbar, just like "Email This!" does.  This would allow emailing links _easier_ than using right-clicking, but not clutter the right-click menu.
Comment 42 Phil DeJarnett 2012-10-21 10:30:46 PDT
This is an unbelievably stupid change.  You remove a harmless, extremely useful feature, one that I use *daily*, just because?  There's no good reason to remove it.  And there's no built-in replacement for sending a link you are hovering over at all.

If you are going to use the "less than 1% of users use this feature" excuse, then I guess we should start stripping Firefox down to the bare minimum of useful features.  Dump most of CSS3 — what a waste, since so few websites use CSS3, it doesn't add anything to most of the web and probably takes up a huge amount of resources.  Or, hell, why bother having a Firefox at all??  Let's just wrap a native webkit renderer in a constantly changing UI!  It won't feel much different, and it will "solve" the performance / memory usage issues overnight!

Thanks for pointing out that I can install yet another extension to put back basic functionality that already existed in Firefox.  Hooray!  That's along with:

* Status-4-Evar, to get the basic, reasonable expectation of seeing a link before I click on it
* Old Lion Fullscreen, because why would I want a fullscreen that is actually *full* screen, and not just 4% bigger than maximized.
* And a bunch of Stylish styles to make the toolbar and other UI elements usable on OS X.

For cripes sake, don't you guys have enough actual development to do without looking for new things to screw up in Firefox?

I love the fact that FF keeps adding new, useless things, like a mediocre developer kit, instead of relying on the much more powerful Firebug.  How about removing that context menu item, so I don't keep cursing at the screen when I click that by accident, instead of the already functional Firebug context menu that I use all the time?

And how often does someone use the context menus for Back, Forward, or Reload???

This is ridiculous.
Comment 43 Phil DeJarnett 2012-10-21 10:33:37 PDT
Oh, hey, that "Email This!" extension isn't being actively maintained, and hasn't been worked on since 2010.  So, there's that.
Comment 44 denweidner 2012-10-21 13:02:56 PDT
If the developers are going to randomly choose to remove functionality of certain add-ons, now I'm worried about the other ones I use regularly.  Which one will be next on the chopping block?  I thought the whole point of using Firefox was that it was CUSTOMIZABLE, meaning I should be able to choose which add-ons I want to use.

I am so sick of all these stupid changes every few weeks!  Maybe it's time to move on to a better browser.
Comment 45 Mark Jones 2012-10-22 05:53:32 PDT
If you think the "E-mail link..." should be returned to the context menu, please vote for and comment on Bug 804124 "Re-add 'E-mail Link...' to context menus" as I don't think commenting here will have as much effect (as it is already marked resolved and relates to *removing* the "Send link" item so won't be re-opened). 

If it gets votes, maybe it will be considered. Tell your friends.

Thanks.
Comment 46 Sergey 2012-10-22 05:58:03 PDT
(In reply to Mark Jones from comment #45)
> If you think the "E-mail link..." should be returned to the context menu,
> please vote for and comment on Bug 804124 "Re-add 'E-mail Link...' to
> context menus" as I don't think commenting here will have as much effect (as
> it is already marked resolved and relates to *removing* the "Send link" item
> so won't be re-opened). 
> 
> If it gets votes, maybe it will be considered. Tell your friends.
> 
> Thanks.

Looks like it duplicates 786185.
Comment 47 Mark Jones 2012-10-22 06:11:24 PDT
(In reply to Sergey from comment #46)
> (In reply to Mark Jones from comment #45)
> > If you think the "E-mail link..." should be returned to the context menu,
> > please vote for and comment on Bug 804124 "Re-add 'E-mail Link...' to
> > context menus" as I don't think commenting here will have as much effect (as
> > it is already marked resolved and relates to *removing* the "Send link" item
> > so won't be re-opened). 
> > 
> > If it gets votes, maybe it will be considered. Tell your friends.
> > 
> > Thanks.
> 
> Looks like it duplicates 786185.

Yeah sorry didn't see that when I searched for it but still, they closed it without even giving an adequate opportunity for people to comment on it. I don't know what is happening in Mozilla these days but if they think they can ride roughshod over user opinion and feedback like this then they have a big rude awakening coming their way when grass-root level users since 0.x start getting annoyed and thinking about jumping ship. Honestly, if I thought there was a better alternative out there I would go. The last thing I want to deal with is another software organisation with a god-complex. That's not the Mozilla I've known over the years.
Comment 48 astro46 2012-10-22 08:55:55 PDT
(In reply to Sergey from comment #46)
> (In reply to Mark Jones from comment #45)
> > If you think the "E-mail link..." should be returned to the context menu,
> > please vote for and comment on Bug 804124 "Re-add 'E-mail Link...' to
> > context menus" as I don't think commenting here will have as much effect (as
> > it is already marked resolved and relates to *removing* the "Send link" item
> > so won't be re-opened). 
> > 
> > If it gets votes, maybe it will be considered. Tell your friends.
> > 
> > Thanks.
> 
> Looks like it duplicates 786185.

I had no idea that bugs/suggestions can be voted on.  or, that the 'send mail' suggestion existed. i did vote for both, but didn't see any way to increase my number of votes, as the voting instructions indicate as possible.

if hardly anyone new that the change (remove "send link") was being considered,  even fewer know that they can vote to restore.
Comment 49 Peter Lairo 2012-10-22 13:51:08 PDT
(In reply to astro46 from comment #48)
> I had no idea that bugs/suggestions can be voted on.

I have been following Mozilla development since its creation (~1999) and cannot remember bug votes ever having any effect on developer decision making. Power corrupts...
Comment 50 Pavel Cvrcek [:JasnaPaka] 2012-10-23 13:08:49 PDT
Because some users ask me about it I developed simple extension Send Link in context menu which add this feature back into context menu. Feedback and testing is welcomed but please on my mail, no spam here. Thanks!

https://addons.mozilla.org/firefox/addon/send-link-in-context-menu/
Comment 51 Paul Menchini 2012-10-23 13:22:06 PDT
Pavel,  Thanks for developing this.  However, it doesn't work like the native menu item in that (1) when hovering over a link in a page and right clicking, it doesn't send that link but sends the link to the page and (2) doesn't provide a subject.

Not sure if that was your intent, but I believe that's how the old one worked.

Regards,

Paul
Comment 52 Paul Menchini 2012-10-23 19:14:22 PDT
Disregard (1) on my previous post--long day.  The old right-click did send the link to the current page.
Comment 53 Alice Wyman 2012-10-24 05:08:35 PDT
(In reply to Paul Menchini from comment #51)
> Pavel,  Thanks for developing this.  However, it doesn't work like the
> native menu item in that (1) when hovering over a link in a page and right
> clicking, it doesn't send that link but sends the link to the page and (2)
> doesn't provide a subject.
> 
> Not sure if that was your intent, but I believe that's how the old one
> worked.


(In reply to Paul Menchini from comment #52)
> Disregard (1) on my previous post--long day.  The old right-click did send
> the link to the current page.

No, the old right-click menu worked both ways (I tested on Firefox 10.0.9 ESR): Before Firefox 16, if you right-clicked directly on a link and chose the "Send link..." item (which was underneath "Save Link as") an email compose window would open with the URL of the actual link you right-clicked on.  If you right-clicked on an empty spot in the webpage and chose "Send Link..." (which was underneath "Save Page as") the email compose window would include a link to the webpage you were on with the page title in the subject line (the same thing that the  Email This! extension does). 

Related discussion: https://support.mozilla.org/en-US/questions/939029#answer-375732
Comment 54 Craig 2012-10-24 11:58:18 PDT
I just submitted a new bug, https://bugzilla.mozilla.org/show_bug.cgi?id=805134, that asks to have this function restored.     

PLEASE go comment on it before it can be closed, out of hand.       Take your comments from here, and repost them there.

Thanks!
Comment 55 hamiglorr 2012-10-25 10:36:19 PDT
(In reply to Craig from comment #54)
> I just submitted a new bug,
> https://bugzilla.mozilla.org/show_bug.cgi?id=805134, that asks to have this
> function restored.     
> 
> PLEASE go comment on it before it can be closed, out of hand.       Take
> your comments from here, and repost them there.
> 
> Thanks!
Comment 56 Silver Mane 2012-10-26 13:23:39 PDT
This sucks!!! I hope your left mouse button falls off!
Comment 57 Mark Jones 2012-10-30 07:43:27 PDT
(In reply to astro46 from comment #48)
> I had no idea that bugs/suggestions can be voted on.  or, that the 'send
> mail' suggestion existed. i did vote for both, but didn't see any way to
> increase my number of votes, as the voting instructions indicate as possible.
> 
> if hardly anyone new that the change (remove "send link") was being
> considered,  even fewer know that they can vote to restore.

Yes hardly anyone knows about bugzilla either. The truth is, feedback about removing items from Firefox should be sought from users at the point where users will see it and in such a manner that the users will be able to easily participate. A bugzilla report and a posting in the hardly-used Mozilla forums is extremely inadequate.

I can tell you that, as a software developer myself, this is very bad management on the part of Mozilla developers. Even for a non-open source, community-driven project this would be bad form. But as an open source, community-driven effort Mozilla is supposed to be driven by the community. While not every decision can be made by referendum, some *should* be as a matter of course, and removing features that have been around for a long time and are so obviously used (and useful) should never be done without proper consultation.

It is my opinion that the Mozilla project is being changed, perhaps not consciously, but it is becoming less of a community project than a venue for a few people to satisfy their own urges. They've lost sight of what Mozilla was set up for in the first place. How many useless features have been / are being added to Firefox (and Thunderbird e.g. chat) that *should* be left as addons? Social API is a ridiculous joke. Leave it to an addon. What happened to the idea of a simple web browser and email client? Sending a link via email has been around since the beginning of the web and is not going away any time soon. They take *this* out and add a whole bloody social API in! Which is going to be the cause of more UI clutter?
Comment 58 Mark Jones 2012-10-30 08:22:40 PDT
Also, you'll notice that all the Mozilla developer blogs have comments turned off. The Firefox Facebook comments are about >60% complaints on most posts. None of those ask for feedback but are mostly just silly marketing junk. 

The developers know they will be swarmed with complaints about their decisions if they allowed that degree of feedback on their posts. But I don't think they want to know. They make their decisions and stick with them regardless of user opinion.

Have a look at this: https://www.facebook.com/about/messenger-for-firefox

The social API is obviously being implemented very closely with Facebook. I strongly suspect this involves a financial arrangement with Mozilla similar to the arrangement Mozilla has with Google for bundling their search engine is as the default. If so, then the inclusion of the social API is driven primarily by money.

Could this have had an influence on removing or hiding alternative social sharing features like "Email link..." because they want to encourage more users to switch to social sharing via the paid for Social API? If so, is that in the spirit of the original Mozilla Firefox?
Comment 59 Peter Lairo 2012-10-30 09:11:03 PDT
(In reply to Mark Jones from comment #58)
> Have a look at this: https://www.facebook.com/about/messenger-for-firefox

Thank you (sarcasm). Now, how to I remove/uninstall "Messenger for Firefox"? I couldn't drag the "f"-button out of my Toolbar nor find the bloatware listed under Add-ons. ARGH.
Comment 60 Peter Lairo 2012-10-30 09:14:41 PDT
(In reply to Peter Lairo from comment #59)
> how to I remove/uninstall "Messenger for Firefox"?

It's buried in the about:config settings: set "social.enabled" to false.
Comment 61 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-10-31 13:38:50 PDT
This is entirely offtopic for this bug, but you can disable Social from the Tools menu, or remove it entirely from the dropdown menu after bug 803344 (which was fixed just recently).

Re: openness to complaints, the size of our user base (several hundreds of millions of users) means that any change we make - even the most trivial - will generate many complaints. We don't always do the best job of it, but balancing being receptive to feedback with not being paralyzed by the inability to change or remove anything is not easy. 0.01% of our user base, using a very conservative estimate, is 20,000 people.
Comment 62 Mark Jones 2012-11-01 07:35:35 PDT
0.01% of test pilot users which was extrapolated as representative of mainstream users. Anyway, extrapolating from various other sources of feedback around Mozilla community I could say more people didn't want this to be removed. Even if it is a lower figure, I'd argue that consideration and weight should also be given to how long a feature has existed, how often those that do use it, use it, how important it is to them, whether resolving it actually solves a problem (not really), and whether a better alternative solution exists (remove/hide "Inspect Element", user-configuration of addon menus items).

Ultimately, 1) test pilot should not be used to make final decisions (given its inherent bias) but as a spring board to soliciting more direct representative feedback. 2) Decisions to remove features should not be made without such direct representative feedback with reference to all considerations outlined above. 3) I'm less concerned (although I am concerned) over this one decision/feature than the processes that led to such a decision potentially resulting in more, similar decisions and the loss of the founding spirit of Firefox to a top-heavy, money-driven approach.

I don't suppose this is the right place to raise the latter issue, but at least I know there's a chance it will be read by those who need to hear it. I don't think the forum or FB fan page has the same kind of traction.

Anyway, I will cease commenting now. There's not much more I can add to what I've already said.
Comment 63 hamiglorr 2012-11-01 11:04:26 PDT
(In reply to Mark Jones from comments #57, #58, & #62)

As before, I agree completely with what you've said - and also with your philosophy about Firefox and Mozilla. I'm sure there are many other Firefox devotees who agree also.  Too bad the top brass at Mozilla seems to have set its teeth and made this small request into a big issue that they refuse to capitulate on.  I do hope it's not a sign of their future attitude.
Comment 64 Craig 2012-11-01 11:38:12 PDT
Gavin:

It sounds like you're working on the development team.   It appears to me that you're speaking from that perspective.   Is that right?   If so, please tell me what the appropriate vehicle for this kind of feedback would be.    If it's not bugzilla, then what is it.
Comment 65 hamiglorr 2012-11-01 12:15:56 PDT
I've submitted the following two feedback items to Firefox:

Sent to "Firefox Made Me Sad" at http://input.mozilla.org/en-US/feedback#sad:
You still haven't put "send link" back onto the right-click context menu - see bugs 239307, 786185, 800565, 803805, 804124, 804424, 805134, and 805949


Sent to "I Have an Idea for Firefox" at http://input.mozilla.org/en-US/feedback#idea:
Put "send link" back onto the right-click context menu - see bugs 239307, 786185, 800565, 803805, 804124, 804424, 805134, and 805949

Feel free to do the same - you're welcome to cut-and-paste the above messages.
Comment 66 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-11-01 13:11:00 PDT
Craig: yes. I'm the Firefox module owner.

Test pilot wasn't used to make a final decision here, it was just one data point.

Firefox decision making has always been "top-down", in that relatively few people are responsible for decision making, based on earned trust in the project. Software design and development by popular vote is not a viable strategy. Which isn't to say that user feedback doesn't play a role - but effectively collecting and interpreting that feedback isn't easy. We don't always do the best job of it. We have input.mozilla.org, and support.mozilla.org, and telemetry, and a team of people monitoring social media, and various other mechanisms for collecting feedback from users. 

Money is the furthest concern in our minds, and the suggestion that it was a factor in this decision is ludicrous. But I know that just stating that isn't going to convince some people - nothing I say will :)

Bugzilla really isn't the best medium for this kind of discussion. If you'd like to continue, can we move this to email? I'm gavin@gavinsharp.com.
Comment 67 hamiglorr 2012-11-13 15:38:20 PST
Found at Bug 755593 - remove tabs-on-bottom mode (https://bugzilla.mozilla.org/show_bug.cgi?id=755593):

dated 2012-05-16
"I think it is time to make controversial changes to simplified and modernized the browser"

If that kind of thinking underlies Firefox & T-bird updates these days, it explains a lot.
Comment 68 Mark Jones 2013-09-09 09:38:34 PDT
(In reply to :Gavin Sharp (mostly away until Sep 13; use gavin@gavinsharp.com for email) from comment #66)
> Money is the furthest concern in our minds, and the suggestion that it was a
> factor in this decision is ludicrous. But I know that just stating that
> isn't going to convince some people - nothing I say will :)

It may be the furthest from your mind and others you know but, if you've been around long enough, it won't be the first time you've seen an open source / community-based project go over to the "dark side" (putting commercial interests ahead of users). However virtuous you think an organization is, it still pays to be ever-vigilant.

Hoping you're right.

Note You need to log in before you can comment on or make changes to this bug.