Closed Bug 23932 Opened 20 years ago Closed 20 years ago

[dogfood] Can't "Save as Draft" Messages with long paragraphs

Categories

(MailNews Core :: Composition, defect, P3)

x86
Windows NT
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: jar, Assigned: jefft)

Details

(Whiteboard: [PDT+])

Create the following outbound message, and try to save as draft.  You'll get an
error (unreadable error message) but you won't be able to save.

a) Open a new message
b) Create a ten character string "123456789 " (note it has a space)
c) Select the ten characters, using the mouse, and cut them to the cut buffer
via Cntrl-C.
d) Do 10 paste operations, creating a 100 charater long line, consisting of 10
words.
e) Select the 100 character line with the mouse, and cut it to the paste buffer.
f) Past the 100 character line 30 times, creating a 3000 character paragraph,
containing 300 words.
e) Try to Save As Draft

You should get a pop-up error message, with a string id that obscures the
meaning if any of the error :-(.

Given the fact that I'm working with beta software, that can crash, I need to be
able to save as draft a message while I'm composing.

There is a second problem in this area, where the composer breaks HTML
paragraphs by adding bangs, but I can't find that bug very easilly until this
one is resolved.  In the follow on bug, examination of the source reveals that
the HTML lines are eventually "broken" at interesting points in the paragraph,
adding bangs (!) around the break point, and corrupcting the message with
these junk bangs hither and yonder :-( :-(
Assignee: beppe → phil
I am assigning this bug to Phil. Phil we don't have control over the save as
draft function. However, the second issue (insertion of !) is ours.

Jar -- please open a new bug, against the editor describing the insertion of !
in the HTML. Please assign it to akkana and cc jfrancis.
Assignee: phil → jefft
Reassign to jefft
Whiteboard: [PDT+]
PDT+
Status: NEW → ASSIGNED
Target Milestone: M13
Uisng build 2000011416m13 on win98, I was able to save as Draft with both an
IMAP and POP account.   I was using HTML for the New Msg and I created a message
using the above scenario.  I also pasted 3 more 100 character lines than stated
in the scenario and still had no problem saving as Draft.   Also, note: I had my
Drafts folder assigned to the  account I was sending from and then I tested with
it assigned to the Local Folder, both worked.  I will check this again when I
get good builds for today 1/18/00, but if there is anymore additional
information to reproduce this please let me know.
QA Contact: lchiang → esther
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Although I could see this is last weeks builds... it appears to be fixed (as
noted by esther).

I'm changing it's status to fixed to expedite the resolution process.  If you
want to see a demo of the problem, pull a buld from early last week, and retry.

Thanks... though I don't know who to thank for the fix :-).

Jim
Using build 2000012109m13 on win98, 2000012108m13 on linux, 2000012108m13 on 
mac this is still working.  Verified
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.