A perl module to extend bugzilla mail to none SENDMAIL platforms

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
15 years ago
6 years ago

People

(Reporter: shahriar_mokhtarzad, Assigned: justdave)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322)
Build Identifier: Bugzilla-2.17.7

I have written a module that allows the user of none SENDMAIL platform configure
and use mail easily in bugzilla-2.17.x. It retaines the SENDMAIL and extends 
the mail to SMTP and SMT_auth. It is in written in perl and uses Net-SMTP & Net-
SMTP_auth from CPAN/ASPN. The configuration is done by editing the module 
(rather simple). All the files that need to be modified are included in the 
attachement. There is also a simple perl program for verifying the mail 
configuration outside of bugzilla. It also has flags for turning on debugging 
in case of problems.

Reproducible: Always
Steps to Reproduce:
1.follow the instruction included in the attachement
2.
3.

Actual Results:  
mail worked on WIN32 platform

Expected Results:  
exactly what I expected

On 3/30/2004 10:17 PM -0800, Shahriar wrote:

> After installing bugzilla on WIN32 and trying to get mail to work with my
> SMTP with
> authentication. I finally wrote a module to handle both the SENDMAIL and the
> SMTP with
> and without authentication. The module seems to work but the configuration
> is sort of
> crude (the parameters have to defined in the module itself) but it is very
> simple
> to configure. Modification to other files is rather simple. So, If your
> group is
> interested I can send you the files to look and if usable, provide them
> to others.

I appreciate the offer to contribute, but we're about to land a patch which
uses Net::SMTP for everything and bypasses the need for a local sendmail
altogether (as well as rewriting a significant chunk of our mail handling
procedures).  See http://bugzilla.mozilla.org/show_bug.cgi?id=84876

On the other hand, that *will* most-likely be landing on the trunk after we
branch for 2.18 (so it would effectively be first available in 2.19.1), so
what you're written still might be useful for folks installing 2.18 on
Win32.  What I would suggest is to file a bug for it and attach the files.
It's very likely that it won't get committed, since the situation is
already being dealt with, but we can certainly point at it in the win32
docs and say "here, this patch might help you out until then".
(Reporter)

Comment 1

15 years ago
Created attachment 145238 [details]
The zip file containes all the files for extending the mail to none SENDMAIL platforms
As mentioned in the quoted email, we already have code to deal with this in what
will soon be version 2.20, so we won't be using this.  Thanks for contributing
though!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
Summary: A perl module to extend bugzilla mail to none SENDMAIL platforms → A perl module to extend bugzilla mail to none SENDMAIL platforms
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.