After DNS timeout names never resolve again.

RESOLVED DUPLICATE of bug 240759

Status

()

Core
Networking
RESOLVED DUPLICATE of bug 240759
14 years ago
11 years ago

People

(Reporter: derf, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       w3m/0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113

Occaisionally after a DNS timeout, the browser will fail to resolve any further
 DNS queries.
Web pages on hosts that were previously resolved still display without issue.
The hosts that will not resolve in Mozilla resolve without issue from the
 command line on the same machine.

This usually occurs in long-running browser sessions (circa three weeks), but
 can occur in as little as five minutes of browsing.
It always happens eventually.
This issue has been present since at least version 1.2, though possibly also
 earlier versions.

The only work around I've found is to close down the browser and restart it,
 after which DNS usually works without issue.


Reproducible: Always
Steps to Reproduce:
1. Leave browser open continuously for a long period of time.
2. Visit a web page with a hostname that is not in cache.

Actual Results:  
Mozilla fails to resolve the hostname.
Mozilla continues to fail to resolve any hostname not in cache until it is shut
 down.


Expected Results:  
Host names should have resolved correctly.

Comment 1

14 years ago
can you reproduce this with 1.7b or current nightly build ?

Comment 2

14 years ago
I was seeing this, but with a recent nightly build, it is fixed.

Mozilla 1.7 RC1 should have the fix.



*** This bug has been marked as a duplicate of 240759 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 3

11 years ago
I won't change the resolution of the bug, but this may be neither a duplicate nor a Mozilla bug.  Windows is reported to cache unsuccessful lookup attempts and fail to look again until the cache has expired, in 5 minutes or so.  See http://kb.mozillazine.org/Error_loading_websites#DNS .
You need to log in before you can comment on or make changes to this bug.