Status

SeaMonkey
General
P3
critical
VERIFIED DUPLICATE of bug 24201
18 years ago
13 years ago

People

(Reporter: Warren Harris, Assigned: David Hyatt)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Go to http://www.angelfire.com/tx2/conradart/index.html
This will cause a popup window to pop up.
Click on the vertical scrollbar, below the thumb.
Crash here with access violation:

nsMenuBarListener::MouseDown(nsIDOMEvent * 0x02c02714) line 218 + 15 bytes
nsEventListenerManager::HandleEvent(nsIPresContext * 0x02ac8470, nsEvent *
0x0012fb68, nsIDOMEvent * * 0x0012f88c, unsigned int 0x00000004, nsEventStatus
* 0x0012fa74) line 700 + 17 bytes
nsXULDocument::HandleDOMEvent(nsXULDocument * const 0x036c50a0, nsIPresContext
* 0x02ac8470, nsEvent * 0x0012fb68, nsIDOMEvent * * 0x0012f88c, unsigned int
0x00000004, nsEventStatus * 0x0012fa74) line 1876
nsXULElement::HandleDOMEvent(nsXULElement * const 0x02218760, nsIPresContext *
0x02ac8470, nsEvent * 0x0012fb68, nsIDOMEvent * * 0x0012f88c, unsigned int
0x00000004, nsEventStatus * 0x0012fa74) line 2783 + 39 bytes
nsXULElement::HandleDOMEvent(nsXULElement * const 0x027dd380, nsIPresContext *
0x02ac8470, nsEvent * 0x0012fb68, nsIDOMEvent * * 0x0012f88c, unsigned int
0x00000004, nsEventStatus * 0x0012fa74) line 2781
nsXULElement::HandleDOMEvent(nsXULElement * const 0x027d8b70, nsIPresContext *
0x02ac8470, nsEvent * 0x0012fb68, nsIDOMEvent * * 0x0012f88c, unsigned int
0x00000004, nsEventStatus * 0x0012fa74) line 2781
nsXULElement::HandleDOMEvent(nsXULElement * const 0x027de540, nsIPresContext *
0x02ac8470, nsEvent * 0x0012fb68, nsIDOMEvent * * 0x0012f88c, unsigned int
0x00000004, nsEventStatus * 0x0012fa74) line 2781
nsXULElement::HandleDOMEvent(nsXULElement * const 0x027de260, nsIPresContext *
0x02ac8470, nsEvent * 0x0012fb68, nsIDOMEvent * * 0x0012f88c, unsigned int
0x00000004, nsEventStatus * 0x0012fa74) line 2781
nsXULElement::HandleChromeEvent(nsXULElement * const 0x027de28c, nsIPresContext
* 0x02ac8470, nsEvent * 0x0012fb68, nsIDOMEvent * * 0x0012f88c, unsigned int
0x00000004, nsEventStatus * 0x0012fa74) line 3763
GlobalWindowImpl::HandleDOMEvent(GlobalWindowImpl * const 0x02afe624,
nsIPresContext * 0x02ac8470, nsEvent * 0x0012fb68, nsIDOMEvent * * 0x0012f88c,
unsigned int 0x00000004, nsEventStatus * 0x0012fa74) line 3082
nsDocument::HandleDOMEvent(nsDocument * const 0x02ac17b0, nsIPresContext *
0x02ac8470, nsEvent * 0x0012fb68, nsIDOMEvent * * 0x0012f88c, unsigned int
0x00000004, nsEventStatus * 0x0012fa74) line 2398
nsGenericElement::HandleDOMEvent(nsIPresContext * 0x02ac8470, nsEvent *
0x0012fb68, nsIDOMEvent * * 0x0012f88c, unsigned int 0x00000004, nsEventStatus
* 0x0012fa74) line 802
AnonymousElement::HandleDOMEvent(AnonymousElement * const 0x02b9e44c,
nsIPresContext * 0x02ac8470, nsEvent * 0x0012fb68, nsIDOMEvent * * 0x0012f88c,
unsigned int 0x00000004, nsEventStatus * 0x0012fa74) line 134 + 31 bytes
nsGenericElement::HandleDOMEvent(nsIPresContext * 0x02ac8470, nsEvent *
0x0012fb68, nsIDOMEvent * * 0x0012f88c, unsigned int 0x00000001, nsEventStatus
* 0x0012fa74) line 792
AnonymousElement::HandleDOMEvent(AnonymousElement * const 0x02ba0c8c,
nsIPresContext * 0x02ac8470, nsEvent * 0x0012fb68, nsIDOMEvent * * 0x00000000,
unsigned int 0x00000001, nsEventStatus * 0x0012fa74) line 134 + 31 bytes
PresShell::HandleEvent(PresShell * const 0x02af6384, nsIView * 0x02ba3f30,
nsGUIEvent * 0x0012fb68, nsEventStatus * 0x0012fa74) line 2742 + 39 bytes
nsView::HandleEvent(nsView * const 0x02ba3f30, nsGUIEvent * 0x0012fb68,
unsigned int 0x00000008, nsEventStatus * 0x0012fa74, int & 0x00000000) line 841
nsView::HandleEvent(nsView * const 0x02ba4820, nsGUIEvent * 0x0012fb68,
unsigned int 0x00000008, nsEventStatus * 0x0012fa74, int & 0x00000000) line 826
nsView::HandleEvent(nsView * const 0x02af3e50, nsGUIEvent * 0x0012fb68,
unsigned int 0x0000001c, nsEventStatus * 0x0012fa74, int & 0x00000000) line 826
nsViewManager::DispatchEvent(nsViewManager * const 0x02af4d60, nsGUIEvent *
0x0012fb68, nsEventStatus * 0x0012fa74) line 1678
HandleEvent(nsGUIEvent * 0x0012fb68) line 69
nsWindow::DispatchEvent(nsWindow * const 0x02af3d24, nsGUIEvent * 0x0012fb68,
nsEventStatus & nsEventStatus_eIgnore) line 502 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012fb68) line 523
nsWindow::DispatchMouseEvent(unsigned int 0x0000012e, nsPoint * 0x00000000
{x=??? y=???}) line 3438 + 21 bytes
ChildWindow::DispatchMouseEvent(unsigned int 0x0000012e, nsPoint * 0x00000000
{x=??? y=???}) line 3656
nsWindow::ProcessMessage(unsigned int 0x00000201, unsigned int 0x00000001, long
0x00370244, long * 0x0012fdc8) line 2723 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x08550a74, unsigned int 0x00000201, unsigned int
0x00000001, long 0x00370244) line 689 + 27 bytes
USER32! 77e71820()
nsDocShell

Updated

18 years ago
Severity: normal → critical

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M14

Updated

18 years ago
Assignee: saari → hyatt
Status: ASSIGNED → NEW

Comment 1

18 years ago
Hyatt is owning this, and has dups
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 2

18 years ago
Dup of 24201.

*** This bug has been marked as a duplicate of 24201 ***

Comment 3

18 years ago
VERIFY duplicate
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.