Crash on Hixie's blog when selecting the stylesheet 'Orange'

RESOLVED DUPLICATE of bug 231776

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 231776
14 years ago
14 years ago

People

(Reporter: Robin Whittleton, Unassigned)

Tracking

({crash})

Trunk
x86
Windows XP
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040401 Firefox/0.8.0+ (mmoy-O2-GL7-SSE2-crc32-quek0)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040401 Firefox/0.8.0+ (mmoy-O2-GL7-SSE2-crc32-quek0)

Hixie's blog crashes if you try and select the 'Orange' stylesheet using the
stylesheet selection icon in the bottom left of the Firefox window.

Reproducible: Always
Steps to Reproduce:
1. Go to http://ln.hixie.ch
2. Click on the stylesheet selector icon
3. Select Orange

Actual Results:  
Crash.

Expected Results:  
Not crashed.

Windows reports:

AppName: firefox.exe	 AppVer: 0.8.0.0	 ModName: firefox.exe
ModVer: 0.8.0.0	 Offset: 002406d1

Visual Studio debugger says:

Unhandled exception at 0x006406d1 in firefox.exe: 0xC0000005: Access violation
reading location 0x00000025.

Comment 1

14 years ago
I confirm with Fx 20040401 XFT-GTK2 with linux (a GNU/Linux Debian with windowmaker)
(Reporter)

Comment 2

14 years ago
After some more digging, I've narrowed down at least part of the problem. If you
look at the stylesheet ( http://ln.hixie.ch/resources/style/orange/ ) and
comment out the line:

html { display: table; margin: 0; border: 0; padding: 2em; border-spacing: 0;
background: #772200; color: #000000; min-height: 100%; width: 100%; }

It no longer crashes. If you delete everything else though and just least that
line it also doesn't crash. So it's an interaction between something on that
line and another part of the sheet.

Comment 3

14 years ago
Does this also crash Mozilla suite?
Keywords: crash
(Reporter)

Comment 4

14 years ago
Just downloaded 1.7b to test this, and yes.

Windows:

AppName: mozilla.exe	 AppVer: 1.7.20040.31616	 ModName: gklayout.dll
ModVer: 1.7.20040.31616	 Offset: 00011668

Visual Studio debugger:

Unhandled exception at 0x60271668 in mozilla.exe: 0xC0000005: Access violation
reading location 0x00000025.

Updated

14 years ago
Assignee: firefox → general
Component: General → Browser-General
Product: Firefox → Browser
QA Contact: general
Version: unspecified → Trunk
dup of bug 231776 via bug 236077

*** This bug has been marked as a duplicate of 231776 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.