If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Search the Knowledge Base" link does not open

RESOLVED DUPLICATE of bug 222874

Status

Tech Evangelism Graveyard
English US
RESOLVED DUPLICATE of bug 222874
14 years ago
3 years ago

People

(Reporter: Steve Yates, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax; BDP)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

When clicking on the link
'http://support.microsoft.com/default.aspx?scid=fh;EN-US;KBHOWTO', the browser
does NOT open the correct page, instead
'http://support.microsoft.com/default.aspx' is displayed.  This link DOES work
in Netscape 7.1.

Reproducible: Always
Steps to Reproduce:
1. Browse to http://support.microsoft.com/default.aspx
2. Click "Search the Knowledge Base"


Actual Results:  
Page appears to not change.

Expected Results:  
Displayed the search form at
http://support.microsoft.com/default.aspx?scid=fh;EN-US;KBHOWTO.

Default install, one of the first pages I tried in Firefox.  Can be duplicated
on multiple PCs.  Works in other browsers, same PCs.
This is a server issue... We make the following HTTP response:

  GET /default.aspx?scid=fh;EN-US;KBHOWTO HTTP/1.1
  Host: support.microsoft.com
  User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040401
  Accept:
text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
  Accept-Language: en,ru;q=0.5
  Accept-Encoding: gzip,deflate
  Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
  Keep-Alive: 300
  Connection: keep-alive

And the server responds with:

  HTTP/1.1 302 Found
  Date: Sat, 03 Apr 2004 07:15:31 GMT
  Server: Microsoft-IIS/6.0
  P3P: policyref="http://www.microsoft.com/w3c/p3p.xml" CP="ALL IND DSP COR ADM
CONo CUR  IVAo IVDo PSA PSD TAI TELo OUR SAMo CNT COM INT NAV ONL PHY PRE PUR UNI"
  X-AspNet-Version: 1.1.4322
  Location: http://support.microsoft.com/default.aspx
  Cache-Control: private
  Content-Type: text/html; charset=iso-8859-1
  Content-Length: 158

Note the "Location" line in the response.  302 is a redirect code; the Location
header says where to redirect to.  Which is exactly what we do.

Looks to me like the server does some random browser-sniffing and screws it up.
Assignee: general → english-us
Component: Browser-General → English US
Product: Browser → Tech Evangelism
QA Contact: general → english-us
Version: Trunk → unspecified

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 222874 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.