dependency graphs stopped working again

RESOLVED DUPLICATE of bug 164085

Status

()

bugzilla.mozilla.org
General
RESOLVED DUPLICATE of bug 164085
14 years ago
7 years ago

People

(Reporter: Nelson Bolyard (seldom reads bugmail), Assigned: myk)

Tracking

Details

BMO has a feature that displays a dynamically built graphic image file
showing the dependency tree in which the selected bug resides.
It seems to stop working from time to time.

When I try to view the dependecy graph for bug 
http://bugzilla.mozilla.org/show_bug.cgi?id=233453
it just times out.
This worked a couple weeks ago.
As people keep adding dependencies, eventually it gets to be enough that it
takes longer than apache can deal with to look them all up.

If the same one sometimes works and sometimes doesn't, it's very likely close to
the limit and it varies on system load.


*** This bug has been marked as a duplicate of 164085 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

14 years ago
Dave, are you sure this is a duplicate?

When I view the dependency tree for the above cited bug, (non-grpahically)
there are less than 20 bugs in the tree.  
20 bugs is too many to show graphically?
Yes.  The dependency tree only goes two directions from the bug you're looking at.

A dependency graph goes two directions from every bug in the tree, and every bug
that finds, etc.  In other words, the graph will keep following every dependency
in every direction from every bug until it runs out of dependencies.
(Reporter)

Comment 4

14 years ago
Well, maybe there shold be an option to produce a graph that reflects the 
non-graphical view.  
Component: Bugzilla: Other b.m.o Issues → General
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.