HTTP Upload attempt kills whole home network.

RESOLVED WONTFIX

Status

()

Core
Networking: HTTP
--
major
RESOLVED WONTFIX
15 years ago
15 years ago

People

(Reporter: Sergei Dolgov, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
Mozilla 1.7a 
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7a) Gecko/20040219

Attempt to upload image on www.trekearth.com "kills" D-Link router in home
network (3 machines on LAN behind router, cable modem connecting to WAN)
(Only power-down-up of router restores functionality).

Upload from Opera 7.0 works fine and instantly.

Tried both HTTP 1.0 and 1.1 - same results.

All machines and router itself are configured with default MTU 1500 (recommended
by provider).

Testing with mentioned site is problematic, because it allows only 1 upload per day.
A Router reset is always the fault of the router itself.
Does it also block after the upload is finished or if you abort it ?
(Reporter)

Comment 2

15 years ago
I should force HARDWARE reset as nothing more helps.
And hardly it is router fault as Opera and IE don't bring it down.
If i abort upload shortly, router restores normal state.
If i allow upload to hang for a while, i'm forced to reset it, as i cannot
contact it from LAN anymore.

Btw, worked ok  with old good 1.0 Mozilla branch.
(Reporter)

Comment 3

15 years ago
for sake - router model is D-Link DI-514
It doesn't matter if it works with IE and Opera.
How should darin find the cause for a bug in a single router and workaround it ?

(Reporter)

Comment 5

15 years ago
I think i will try it myself. With upload on other sites and HTTP logging.
Maybe will try, if i have found this problem exists for other upload-sites on
neighbour's router (and same provider).

Though, your arguments aren't so strong.

If some application crashes OS, we can blame OS for bad design, but if other
apps with same functionality don't do it - there is place to think at problem.
Our case is similar - Mozilla manages to exploit/saturate TCP/IP stack in
proprietary router OS with quite trivial action.


I will try with 1.7 final when it is out, and if it works perfectly, close bug,
but it don't make this case less interesting for real networking-programmer.
"If some application crashes OS, we can blame OS for bad design, but if other
apps with same functionality don't do it - there is place to think at problem."

That`s wrong. There are known bugs in some video drivers that cause the whole OS
(winXP/2k) to freeze. This happens only with Mozilla but it`s a driver problem and 
nvidia fixed their driver.

This is more complicated because this problem is only with your router. I bet
you can't reproduce that on 99% of all other cheap home-routers.
(Reporter)

Comment 7

15 years ago
Though, it may be symptom of some real problem.
Hiding head in sand isn't best style for Q&A and bug hunting:)

Maybe it is even dup of some existing bug, but it isn't obvious for me, as i
don't follow mozilla networking development, but it may be much more obvious for
Darin.
I will try it also with direct connection to internet and via FreeBSD router.
Also, as i said, there wasn't such problem with older version of Mozilla.
(Reporter)

Comment 8

15 years ago
Tested situation with 1.7a for BeOS (Mozilla 1.7a
Mozilla/5.0 (BeOS; U; BeOS BePC; en-US; rv:1.7a) Gecko/20040205) here:
 http://www.tud.ttu.ee/~t020542/upload.htm
same sad result. So i will continue investigations.
(Reporter)

Comment 9

15 years ago
Closing bug.
Brought meighbours router here and tested. Works.

Though, that remains quite confusing, while Opera and IE didn't brought it down.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
IS it the same router or a different one ?
(Reporter)

Comment 11

15 years ago
>IS it the same router or a different one ?
Same type - DI-514. With same version of firmware.
But bought two weeks later.

Off-topic - i hate current situation with new hardware production rush with zero
Q&A testing. Misterious routers, harddisks which work just warranty time and no
more etc etc :((((
Some routers have an option (sometimes hidden) to do very verbose logging to
debug stuff like this.  Perhaps you want to look into that.
(Reporter)

Comment 13

15 years ago
Don't hang and don't kill router if Mozilla is configured to work trough proxy.
You need to log in before you can comment on or make changes to this bug.