CUA's java web banker applet does not work in FireBird/FireFox

RESOLVED WORKSFORME

Status

Core Graveyard
Java: OJI
--
major
RESOLVED WORKSFORME
14 years ago
8 years ago

People

(Reporter: Douglas Perkins, Assigned: Kyle Yuan)

Tracking

({regression})

Trunk
x86
Windows XP
regression

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

When logging into Credit Union Australia's Web Banker, the fullscreen javascript
popup page loads and the embedded internet banking applet starts to load. The
applet says Connecting...Please Wait. And it never gets any further than this. I
have tried Mozilla/Firebird/FireFox on different platforms
(windows/redhat/xandros etc) and on different hardware configs, exact same
problem (using the latest sun java + registry patch obviously). MS's IE 5/6 and
KDE's Konqueror work perfectly fine with this applet (using the same sun java
version). On IE/Konqueror it briefly shows the connecting please wait message
but loads up the login screen shortly after. I think this is a bug in mozilla's
java implementation and especially since I need to use a registry patch for
mozilla, firebird and firefox to see java even exists.

Reproducible: Always
Steps to Reproduce:
1.log onto www.cua.com.au  (Credit Union Australia's Website)
2.Click on Log In Web Banker (this loads a javascript popup box)
3.Watch the embedded java applet loading..it never gets any further.

Actual Results:  
Never gets any further, exact same results.

Expected Results:  
Continued loading up the java applet and presented the login screen within the
java applet itself.

Mozilla/Firebird/Firefox do not crash, the java applet simply does not continue
to load up, using different themes does not matter as I think this is simply a
small error in the java implementation of the mozilla project. Other internet
banking java applets *do* work such as Commonwealth Australia's Internet Banking
and ANZ Internet Banking.

Comment 1

14 years ago
Moving to oji

This used to work in 1.4.x, but is broken now.
Assignee: firefox → kyle.yuan
Status: UNCONFIRMED → NEW
Component: General → Java: OJI
Ever confirmed: true
Product: Firefox → Browser
Version: unspecified → Trunk
(Assignee)

Comment 2

14 years ago
Narrow down the time frame of te regression: it works in 1.5rc1 but is broken in
1.5rc2.
(Assignee)

Comment 3

14 years ago
*** Bug 226917 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Keywords: regression
(Assignee)

Comment 4

14 years ago
Reporter said via email that "Firefox 0.93 and Java 1.4.2._05-b04 work fine with
www.cua.com.au's web applet! I believe this is the first 'new' version that it
works fine with! This is on windows 2000, sp4. I believe it is a universal fix. "

So mark WFM.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.