Scrolling algorithm should be improved à la Smoothwheel

VERIFIED DUPLICATE of bug 206438

Status

()

--
enhancement
VERIFIED DUPLICATE of bug 206438
15 years ago
7 years ago

People

(Reporter: gkn, Assigned: bugzilla)

Tracking

1.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7b) Gecko/20040321 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7b) Gecko/20040321 Firefox/0.8.0+

The current smooth scroll implementation isn't smooth at all. The algorithm from
the Smoothwheel extension should be used instead.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
hi.

i'm the author of smoothwheel.
there are currently (at least) 2 more related bugs:

1. actual implementation of smooth scroll: bug 174049.
2. request to replace the current smooth scroll woth smoothwheel's algorithms: bug
206438.

i'm willing to help implementing my algorithms into mozilla. see bug 206438 for
more details.

avih
reopen the original bug, since the situation has changed.

*** This bug has been marked as a duplicate of 206438 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
V.Duplicate
Status: RESOLVED → VERIFIED
Version: unspecified → 1.0 Branch
You need to log in before you can comment on or make changes to this bug.