If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

Core Graveyard
Profile: BackEnd
P3
blocker
VERIFIED FIXED
18 years ago
2 years ago

People

(Reporter: cpratt, Assigned: selmer (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build ID: 2000011408
Platform: Linux

To reproduce:
- From the console, try either ./mozilla or ./mozilla -installer

Result:

When I start the build with /mozilla, the console says:

DocLoaderFactory: Unable to create ContentViewer for
command=view,content-type=application/x-unknown-content-type

When I start it with ./mozilla -installer, it says:

CSSLoaderImpl::DidLoadStyle: Load of URL
'chrome://global/skin.%40X$27$27$08$10' failed. Error code: 16389

Expected result: it should launch.

Comment 1

18 years ago
I also see an empty CreateProfileWizard with no buttons operable.
Error in console after error mentioned above:
Javascript Error: TypeError: wizardManager has no properties
(Assignee)

Comment 2

18 years ago
From sspitzer:

I run with -installer on linux with one profile, so I skip all the
profile ui and go right to the browser.

I get similar error messages for the browser chrome:

CSSLoaderImpl::DidLoadStyle: Load of URL 'chrome://global/skin/.%08%10'
failed.  Error code: 16389
(Assignee)

Comment 3

18 years ago
From Waterson:

Could be related to 23967, where I'm seeing bloaty create a corrupted
URL from a "res:" spec.

---

I think this bug should only focus on the DocLoader problem assuming the
corrupted URL problem is 23967.  Steve

Comment 4

18 years ago
If I use ./mozilla -installer and automigrate one profile, I hang on the error:
DocLoaderFactory:Unable to create ContentViewer for command=view,
content-type=application/x-unknown-content-type
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
this should be fixed, I just backed out andreas.

Comment 6

18 years ago
res: was never a protocol we used. It was an interim thing I used to get the new
resource implementation running. Note that resource: is implemented by
netwerk/protocol/res (not netwerk/protocol/resource which is the old one).

Comment 7

18 years ago
*** Bug 23959 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Component: Profile Manager → Profile Manager BackEnd

Comment 8

18 years ago
Moving all Profile Manager bugs to new Profile Manager Backend component.
Profile Manager component to be deleted.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 9

18 years ago
build 2000011908
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.