address bar autocomplete does not fill in protocol to url

RESOLVED FIXED in Firefox 2 beta1

Status

()

Firefox
Address Bar
P5
minor
RESOLVED FIXED
14 years ago
11 years ago

People

(Reporter: Michal Kašpar, Assigned: Brett Wilson)

Tracking

unspecified
Firefox 2 beta1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040227 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040227 Firefox/0.8

If I start writing url in address bar, it offers possible autocompletes. If I
chose one and I started writing with host address, it doesn't fill in protocol
until I press enter, which is problem, if I want to change some part of this
url. If I start writing with protocol, everything works ok.
Example:
url https://aa.bb.cc/xxx
I start writing 'aa', whole url appears in list but when I want to change xxx to
xxy, https:// disapears, so I have to fill it in again.
If I start to write 'https://aa', list is the same and I can edit any part of
url and protocol ramains where it should.

Reproducible: Always
Steps to Reproduce:
1. url https://aa.bb.cc/xxx
2. start writing 'aa'
3. choose from list one and try to edit it

Actual Results:  
protocol part of url disapears

Expected Results:  
Either protocol part should remain or protocol should not apear in the list. I
would prefer first possibility.

Comment 1

14 years ago
Michal: Could you retest autocomplete with Firefox 0.9?
(Reporter)

Comment 2

13 years ago
Firefox 0.9.3 (from Debian) and it's still the same. I tried vanilla 0.9 and it
did not help either.

Comment 3

13 years ago
I see the same problem... while "hiding" the "http://www." part can be useful to
directly read the actual website name, I feel it souhld be "remembered" by
Mozilla anyway.
Ora maybe https urls should have yellow BG anyway, to be quickly identified even
if they don0't show the protocol name.

Comment 4

13 years ago
Firefox 1.0, still reproducable

Comment 5

13 years ago
Still reproducable with Firefox 1.0.3 (OS X) and 1.0.2 (Debian i386)

Comment 6

12 years ago
Bug 233229 is a similar problem in Core/Location Bar.

Comment 7

12 years ago
*** Bug 286124 has been marked as a duplicate of this bug. ***

Comment 8

12 years ago
*** Bug 305186 has been marked as a duplicate of this bug. ***

Comment 9

12 years ago
*** Bug 310926 has been marked as a duplicate of this bug. ***

Comment 10

12 years ago
*** Bug 293136 has been marked as a duplicate of this bug. ***

Comment 11

12 years ago
I don't have the privs, but the bug is not Linux-specific, I've confirmed it
both on Windows and FreeBSD.

Comment 12

12 years ago
I can confirm this on Windows 2000 and XP using Firefox 1.5 Beta 2 as well.  It
also occurs on SeaMonkey on all platforms [bug 233229].
OS: Linux → All
Hardware: PC → All
Bug 233299 is now marked fixed, but it doesn't seem to be easy to port over to Firefox. Yay for forking.
(Assignee)

Updated

12 years ago
Assignee: bugs → brettw
Priority: -- → P5
Target Milestone: --- → Firefox 2 beta1

Comment 14

12 years ago
I think this is the same bug that causes the following, quite annoying behaviour: If I start to type an address where the part after http://www. begins with t or p and then choose the url from the combobox list using arrow keys, it 1) omits the www. part and more annoyingly 2) substitutes ttp:// or p:// for http://, depending on the first character typed. Probably does the same for other protocols, too.
(Assignee)

Comment 15

12 years ago
This was fixed on trunk and branch by bug 320181.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 16

12 years ago
WORKAROUND: The Autocomplete Manager extension (https://addons.mozilla.org/extensions/moreinfo.php?id=2300) includes a bugfix for this.

Comment 17

12 years ago
*** Bug 336079 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.