M17rc2 crash writing email [@ MSVCRT.DLL - nsVoidArray::SizeTo]

RESOLVED WORKSFORME

Status

MailNews Core
Composition
--
critical
RESOLVED WORKSFORME
14 years ago
7 years ago

People

(Reporter: jay, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({crash, qawanted, topcrash+})

Trunk
x86
All
crash, qawanted, topcrash+
Bug Flags:
blocking1.7 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: appears to be [fixed by a checkin to another bug], crash signature)

(Reporter)

Description

14 years ago
This is a topcrash with Mozilla 1.7 beta.  Users are crashing while writing
email.  Here is the latest from Talkback:

Count   Offset    Real Signature
[ 15   MSVCRT.DLL + 0x1798 (0x78001798) 8cdfe2f9 - MSVCRT.DLL + 0x1798
(0x78001798) ]
[ 4   MSVCRT.DLL + 0x1798 (0x78001798) 738e66d5 - MSVCRT.DLL + 0x1798 (0x78001798) ]
 
     Crash date range: 01-APR-04 to 31-MAR-04
     Min/Max Seconds since last crash: 69 - 72077
     Min/Max Runtime: 3206 - 108910
 
     Count   Platform List 
     18   [Windows 98 4.10 build 67766446]   
     1   [Windows 98 4.10 build 67766222]   
 
     Count   Build Id List 
     19   2004031615
 
     No of Unique Users         7
 
 Stack trace(Frame) 

	 MSVCRT.DLL + 0x1798 (0x78001798)  
	 MSVCRT.DLL + 0x36e1 (0x780036e1)  
	 nsVoidArray::SizeTo
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsVoidArray.cpp
 line 188] 
	 nsVoidArray::GrowArrayBy
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsVoidArray.cpp
 line 282] 
	 nsVoidArray::InsertElementAt
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsVoidArray.cpp
 line 397] 
	 nsCOMArray_base::InsertObjectAt
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsCOMArray.cpp
 line 88] 
	 nsRDFDOMNodeList::AppendNode
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/content/xul/content/src/nsRDFDOMNodeList.cpp
 line 123] 
	 XPTC_InvokeByIndex
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp
 line 102]  
 
     (12033)	Comments: Typing in mailer.
     (9635)	Comments: My email software keeps shutting down in the middle of
composing a new email message.  
     (9525)	Comments: I was about to reply  to a message. The message was in
HTML and I prefer plaintext  and I set the preferences to compose in plain text
 and then closed the message  and re-opened it. I was typing in the reply and
Mozilla performed an illegal operation.   
     (9525)	Comments:  MOZILLA caused an invalid page fault in  module
MSVCRT.DLL at 0177:78001798.  Registers:  EAX=00760008 CS=0177 EIP=78001798
EFLGS=00010202  EBX=00760138 SS=017f ESP=0064e5c8 EBP=0064e5e4  ECX=00762de4
DS=017f ESI=03101a2c FS=356f  EDX=00000008 ES=017f
     (9525)	Comments:  EDI=00000016 GS=0000  Bytes at CS:EIP:  8b 59 04 89 4e 08
89 5e 04 89 71 04 8b 4e 04 89   Stack dump:  00760138 00000100 03101a30 00762da4
00000001 00000071 00000090 0064e634 780036e1 00760138 03101abc 01c90ef0 03101a30
00000090 0314f0f4 0000003e 
     (8383)	Comments: When i reply an email and use the backspace button to
correct  the prgoraram collapse ( it happen at leaset once a week ).  I tried to
upgrade to this beta version since it happen on the 1.6 but still have this problem.
 
And some more user comments:
(7770)	Comments: Deleting text in the Composer window in Mail/News
     (5278)	Comments: Typing in email composer window
     (5276)	Comments: Trying to type a message in the email composer
window--crashed after the first two characters
(Reporter)

Comment 1

14 years ago
Updating summary M17beta->M17rc1.  This continues to be a topcrash for Mozilla
1.7 rc1:

     Count   Offset    Real Signature
[ 5   MSVCRT.DLL + 0xd16a (0x7800d16a) 16c25835 - MSVCRT.DLL + 0xd16a (0x7800d16a) ]
 
     Crash date range: 26-APR-04 to 28-APR-04
     Min/Max Seconds since last crash: 3056 - 126628
     Min/Max Runtime: 49502 - 176130
 
     Count   Platform List 
     5   [Windows 98 4.10 build 67766446]   
 
     Count   Build Id List 
     5   2004042109
 
     No of Unique Users         2
 
 Stack trace(Frame) 

	 MSVCRT.DLL + 0xd16a (0x7800d16a)  
	 MSVCRT.DLL + 0x11b77 (0x78011b77)  
	 nsVoidArray::SizeTo
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsVoidArray.cpp
 line 188] 
	 nsVoidArray::GrowArrayBy
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsVoidArray.cpp
 line 282] 
	 nsVoidArray::InsertElementAt
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsVoidArray.cpp
 line 397] 
	 nsCOMArray_base::InsertObjectAt
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsCOMArray.cpp
 line 88] 
	 nsRDFDOMNodeList::AppendNode
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/content/xul/content/src/nsRDFDOMNodeList.cpp
 line 123] 
	 nsXULElement::GetChildNodes
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/content/xul/content/src/nsXULElement.cpp
 line 664]  
 
     (30590)	Comments: I was typing an e mail and it crashed in the middle of
the text.  I had not pushed send was just typing.  Thanks
 
====================================================================================================
     Count   Offset    Real Signature
[ 4   MSVCRT.DLL + 0x1798 (0x78001798) 5cda3a35 - MSVCRT.DLL + 0x1798 (0x78001798) ]
[ 2   MSVCRT.DLL + 0x1798 (0x78001798) c15838c5 - MSVCRT.DLL + 0x1798 (0x78001798) ]
 
     Crash date range: 24-APR-04 to 27-APR-04
     Min/Max Seconds since last crash: 537 - 22399
     Min/Max Runtime: 5244 - 65026
 
     Count   Platform List 
     3   [Windows 98 4.10 build 67766446]   
     2   [Windows 98 4.90 build 73010104]   
     1   [Windows 98 4.10 build 67766222]   
 
     Count   Build Id List 
     6   2004042109
 
     No of Unique Users         3
 
 Stack trace(Frame) 

	 MSVCRT.DLL + 0x1798 (0x78001798)  
	 MSVCRT.DLL + 0x36e1 (0x780036e1)  
	 nsVoidArray::SizeTo
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsVoidArray.cpp
 line 188] 
	 nsVoidArray::GrowArrayBy
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsVoidArray.cpp
 line 282] 
	 nsVoidArray::InsertElementAt
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsVoidArray.cpp
 line 397] 
	 nsCOMArray_base::InsertObjectAt
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsCOMArray.cpp
 line 88] 
	 nsRDFDOMNodeList::AppendNode
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/content/xul/content/src/nsRDFDOMNodeList.cpp
 line 123] 
	 nsXULElement::GetChildNodes
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/content/xul/content/src/nsXULElement.cpp
 line 664]  
 
     (31497)	URL: centraloregon4kerry.com
     (31497)	Comments: just writing a reply to my parents and poh_shit it was gone.
     (31380)	URL: centraloregon4kerry.com
     (31380)	Comments: repling to and email started typing crashed
     (30899)	Comments: answering an email
     (30877)	Comments: writing email
     (30804)	Comments: typing reply to email and hit back space and crashed. 
Dreamweaver sync running in background.
Summary: M17beta crash [@ MSVCRT.DLL - nsVoidArray::SizeTo] composing email → M17rc1 crash writing email [@ MSVCRT.DLL - nsVoidArray::SizeTo]
(Reporter)

Comment 2

14 years ago
Marking this topcrash+ to make sure we look at this soon.  It's been a major
topcrasher for a while now.  I have not been able to reproduce this, but
hopefully the stack (which hasn't changed since I logged this bug) and the
lastest user comments (which all continue to be mail compose related) can help
us understand what might be happening.

Here are the latest comments from Talkback data:

(48256)	Comments: composing email
     (47715)	Comments: composing an email reply.
     (46457)	Comments: Composing email.    I had suspected that perhaps copying
URL's or email addresses might have had somehting to do with these types of
crashes.  The message I was typing was just text fromt he keyboard.  Best of
luck with this.
     (43994)	Comments: Writng a fucking mail
     (43943)	Comments: Typing a mail message ... I think I'll go back in Mozilla
1.5!!!
     (43936)	Comments: Typing a mail message with attachment  with Navigator
window open
     (43308)	Comments: Typing a mail message with attachment
     (43263)	Comments: Replying a mail
     (43119)	Comments: Composing a mail with browser window open
     (42093)	Comments: composing email
     (41333)	Comments: I was typing an email.  I had highlighted two lines of
text and  pressed delete.  Then I got the Windows has performed an illegal
operation.    FYI  imediatly before I selected that text I had just copied a url
into the mail compose window.  Plain text
     (41333)	Comments:  mode.
(48891)	URL:
http://online.wsj.com/public/resources/documents/info-webten04-frame.html
     (48891)	Comments: MOZILLA caused an invalid page fault in  module
MSVCRT.DLL at 0177:7800d16a.  Registers:  EAX=00770008 CS=0177 EIP=7800d16a
EFLGS=00010283  EBX=00000007 SS=017f ESP=0065f0cc EBP=0065f0e8  ECX=00771f88
DS=017f ESI=03a8864c FS=558f  EDX=00000010 ES=017f
     (48891)	Comments:  EDI=0000000f GS=0000  Bytes at CS:EIP:  8b 5c d1 04 8d
0c d1 89 5e 04 89 4e 08 89 71 04   Stack dump:  00000000 00000100 03a886d0
00771f88 00000000 00000080 00000110 0065f148 78011b77 00770138 03a8864c 052f0ef0
03a886d0 00000090 03b0f0e4 0000003e   
     (48051)	Comments: Another Crash at the *same* EIP in Composer  while doing
Backspaces  This is  at least  the fifth one.....    2004 May 15th  02h32 
MOZILLA caused an invalid page fault in  module MSVCRT.DLL at 0177:7800d16a. 
Registers:  EAX=00770008 CS=0177 EIP=7800d16a
     (48051)	Comments:  EFLGS=00010283  EBX=00000009 SS=017f ESP=0065e5bc
EBP=0065e5d8  ECX=00773bc0 DS=017f ESI=03a0f00c FS=7187  EDX=00000012 ES=017f
EDI=0000001d GS=0000  Bytes at CS:EIP:  8b 5c d1 04 8d 0c d1 89 5e 04 89 4e 08
89 71 04   Stack dump:  00000000 00000100
     (48051)	Comments:  03a0f0b0 00773bc0 00000000 000000a0 00000130 0065e638
78011b77 00770138 03a0f00c 04040ef0 03a0f0b0 00000090 03a1f0c4 0000003e    
MOZILLA caused an invalid page fault in  module MSVCRT.DLL at 0177:7800d16a. 
Registers:  EAX=00770008 CS=0177 EIP=7800d16a
     (48051)	Comments:  EFLGS=00010293  EBX=00000001 SS=017f ESP=0065e5bc
EBP=0065e5d8  ECX=00772fa8 DS=017f ESI=039da75c FS=623f  EDX=0000000a ES=017f
EDI=00000017 GS=0000  Bytes at CS:EIP:  8b 5c d1 04 8d 0c d1 89 5e 04 89 4e 08
89 71 04  Stack dump:  00000000 00000100
     (48051)	Comments:  039da780 00772fa8 00000000 00000020 000000b0 0065e638
78011b77 00770138 039da75c 02bd0ef0 039da780 00000090 044372a4 0000003e   
MOZILLA caused an invalid page fault in  module MSVCRT.DLL at 0177:7800d16a. 
Registers:  EAX=00770008 CS=0177 EIP=7800d16a
     (48051)	Comments:  EFLGS=00010202  EBX=00770138 SS=017f ESP=0065e5bc
EBP=0065e5d8  ECX=00773bc0 DS=017f ESI=03d6f00c FS=0ec7  EDX=00000008 ES=017f
EDI=0000001d GS=0000  Bytes at CS:EIP:  8b 5c d1 04 8d 0c d1 89 5e 04 89 4e 08
89 71 04  Stack dump:  00000000 00000100
     (48051)	Comments:  03d6f010 00773bc0 00000001 ffffffff 00000090 0065e638
78011b77 00770138 03d6f09c 03d80ef0 03d6f010 00000090 03d7f044 0000003e   
MOZILLA caused an invalid page fault in  module MSVCRT.DLL at 0177:7800d16a. 
Registers:  EAX=00770008 CS=0177 EIP=7800d16a
     (48051)	Comments:  EFLGS=00010202  EBX=00770138 SS=017f ESP=0065e5bc
EBP=0065e5d8  ECX=007735b4 DS=017f ESI=04ce55cc FS=544f  EDX=00000008 ES=017f
EDI=0000001a GS=0000  Bytes at CS:EIP:  8b 5c d1 04 8d 0c d1 89 5e 04 89 4e 08
89 71 04  Stack dump:  00000000 00000100
     (48051)	Comments:  04ce55d0 007735b4 00000001 00000041 00000090 0065e638
78011b77 00770138 04ce565c 04d10ef0 04ce55d0 00000090 04cd17b4 0000003e   
MOZILLA caused an invalid page fault in  module MSVCRT.DLL at 0177:7800d16a. 
Registers:  EAX=00770008 CS=0177 EIP=7800d16a
     (48051)	Comments:  EFLGS=00010283  EBX=0000001a SS=017f ESP=0065f30c
EBP=0065f328  ECX=00772da4 DS=017f ESI=054b4cac FS=57a7  EDX=00000034 ES=017f
EDI=00000016 GS=0000  Bytes at CS:EIP:  8b 5c d1 04 8d 0c d1 89 5e 04 89 4e 08
89 71 04  Stack dump:  00000000 00000309
     (48051)	Comments:  054b4e60 00772da4 00000000 000001b0 00000350 0065f388
78011b77 00770138 054b4cac 05500ce0 054b4e60 000001a0 00000301 054ff6b8    
     (46538)	Comments: emailing an attachment
     (46440)	Comments: Answering a mail.
     (45721)	Comments: I was typing in Composer....    Notice that the last
*four* crashes occur at the same EIP --  module MSVCRT.DLL at 0177:7800d16a. 
Registers:  EAX=00770008 CS=0177 EIP=7800d16a     Thus  it is a highly
reproducible and debuggable bug      MOZILLA caused
     (45721)	Comments:  an invalid page fault in  module MSVCRT.DLL at
0177:7800d16a.  Registers:  EAX=00770008 CS=0177 EIP=7800d16a EFLGS=00010293 
EBX=00000001 SS=017f ESP=0065e5bc EBP=0065e5d8  ECX=00772fa8 DS=017f
ESI=039da75c FS=623f  EDX=0000000a ES=017f EDI=00000017
     (45721)	Comments:  GS=0000  Bytes at CS:EIP:  8b 5c d1 04 8d 0c d1 89 5e 04
89 4e 08 89 71 04   Stack dump:  00000000 00000100 039da780 00772fa8 00000000
00000020 000000b0 0065e638 78011b77 00770138 039da75c 02bd0ef0 039da780 00000090
044372a4 0000003e         MOZILLA
     (45721)	Comments:  caused an invalid page fault in  module MSVCRT.DLL at
0177:7800d16a.  Registers:  EAX=00770008 CS=0177 EIP=7800d16a EFLGS=00010202 
EBX=00770138 SS=017f ESP=0065e5bc EBP=0065e5d8  ECX=00773bc0 DS=017f
ESI=03d6f00c FS=0ec7  EDX=00000008 ES=017f
     (45721)	Comments:  EDI=0000001d GS=0000  Bytes at CS:EIP:  8b 5c d1 04 8d
0c d1 89 5e 04 89 4e 08 89 71 04   Stack dump:  00000000 00000100 03d6f010
00773bc0 00000001 ffffffff 00000090 0065e638 78011b77 00770138 03d6f09c 03d80ef0
03d6f010 00000090 03d7f044 0000003e        
     (45721)	Comments:  MOZILLA caused an invalid page fault in  module
MSVCRT.DLL at 0177:7800d16a.  Registers:  EAX=00770008 CS=0177 EIP=7800d16a
EFLGS=00010202  EBX=00770138 SS=017f ESP=0065e5bc EBP=0065e5d8  ECX=007735b4
DS=017f ESI=04ce55cc FS=544f  EDX=00000008 ES=017f
     (45721)	Comments:  EDI=0000001a GS=0000  Bytes at CS:EIP:  8b 5c d1 04 8d
0c d1 89 5e 04 89 4e 08 89 71 04   Stack dump:  00000000 00000100 04ce55d0
007735b4 00000001 00000041 00000090 0065e638 78011b77 00770138 04ce565c 04d10ef0
04ce55d0 00000090 04cd17b4 0000003e        
     (45721)	Comments:  MOZILLA caused an invalid page fault in  module
MSVCRT.DLL at 0177:7800d16a.  Registers:  EAX=00770008 CS=0177 EIP=7800d16a
EFLGS=00010283  EBX=0000001a SS=017f ESP=0065f30c EBP=0065f328  ECX=00772da4
DS=017f ESI=054b4cac FS=57a7  EDX=00000034 ES=017f
     (45721)	Comments:  EDI=00000016 GS=0000  Bytes at CS:EIP:  8b 5c d1 04 8d
0c d1 89 5e 04 89 4e 08 89 71 04   Stack dump:  00000000 00000309 054b4e60
00772da4 00000000 000001b0 00000350 0065f388 78011b77 00770138 054b4cac 05500ce0
054b4e60 000001a0 00000301 054ff6b8     
     (44874)	Comments: Backspacing in Composer  (This is not the first time) 
MOZILLA caused an invalid page fault in  module MSVCRT.DLL at 0177:7800d16a. 
Registers:  EAX=00770008 CS=0177 EIP=7800d16a EFLGS=00010202  EBX=00770138
SS=017f ESP=0065e5bc EBP=0065e5d8  ECX=00773bc0
     (44874)	Comments:  DS=017f ESI=03d6f00c FS=0ec7  EDX=00000008 ES=017f
EDI=0000001d GS=0000  Bytes at CS:EIP:  8b 5c d1 04 8d 0c d1 89 5e 04 89 4e 08
89 71 04   Stack dump:  00000000 00000100 03d6f010 00773bc0 00000001 ffffffff
00000090 0065e638 78011b77 00770138 03d6f09c
     (44874)	Comments:  03d80ef0 03d6f010 00000090 03d7f044 0000003e   
     (44866)	Comments: Using Backspace key repeatedly to join two lines  (This
is not the fist time this happens)  MOZILLA caused an invalid page fault in 
module MSVCRT.DLL at 0177:7800d16a.  Registers:  EAX=00770008 CS=0177
EIP=7800d16a EFLGS=00010202  EBX=00770138 SS=017f
     (44866)	Comments:  ESP=0065e5bc EBP=0065e5d8  ECX=007735b4 DS=017f
ESI=04ce55cc FS=544f  EDX=00000008 ES=017f EDI=0000001a GS=0000  Bytes at
CS:EIP:  8b 5c d1 04 8d 0c d1 89 5e 04 89 4e 08 89 71 04   Stack dump:  00000000
00000100 04ce55d0 007735b4 00000001 00000041
     (44866)	Comments:  00000090 0065e638 78011b77 00770138 04ce565c 04d10ef0
04ce55d0 00000090 04cd17b4 0000003e   
     (44258)	Comments: Attempting to re-activate the computer after going into
suspend mode with Compaq Armada 7400 and USB NIC.
     (42038)	Comments: typing an email
     (41675)	Comments: typing an email response and it crashed.


Keywords: topcrash → topcrash+
(Reporter)

Comment 3

14 years ago
Updating summary M17rc1 -> M17rc2
Summary: M17rc1 crash writing email [@ MSVCRT.DLL - nsVoidArray::SizeTo] → M17rc2 crash writing email [@ MSVCRT.DLL - nsVoidArray::SizeTo]
(Reporter)

Comment 4

14 years ago
And a set of crashes from Mozilla 1.7 rc2 with some comments that might be helpful:

Count   Offset    Real Signature
[ 1   MSVCRT.DLL + 0xd16a (0x7800d16a) 16c25835 - MSVCRT.DLL + 0xd16a (0x7800d16a) ]
[ 1   MSVCRT.DLL + 0xd16a (0x7800d16a) 0aaf828b - MSVCRT.DLL + 0xd16a (0x7800d16a) ]
 
     Crash date range: 18-MAY-04 to 19-MAY-04
     Min/Max Seconds since last crash: 3935 - 5178
     Min/Max Runtime: 3935 - 5178
 
     Count   Platform List 
     2   [Windows 98 4.10 build 67766446]   
 
     Count   Build Id List 
     2   2004051408
 
     No of Unique Users         2
 
 Stack trace(Frame) 

	 MSVCRT.DLL + 0xd16a (0x7800d16a)  
	 MSVCRT.DLL + 0x11b77 (0x78011b77)  
	 nsVoidArray::SizeTo
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsVoidArray.cpp
 line 188] 
	 nsVoidArray::GrowArrayBy
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsVoidArray.cpp
 line 282] 
	 nsVoidArray::InsertElementAt
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsVoidArray.cpp
 line 397] 
	 nsCOMArray_base::InsertObjectAt
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsCOMArray.cpp
 line 88] 
	 nsRDFDOMNodeList::AppendNode
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/content/xul/content/src/nsRDFDOMNodeList.cpp
 line 123] 
	 nsXULElement::GetChildNodes
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/content/xul/content/src/nsXULElement.cpp
 line 664]  
 
     (52388)	Comments: Were repling to a message (probaly in Unicode  Cyrillic
and Latvian languages were in the message).    Crashed during switching from
English to Russian keyboard layout.
     (50837)	Comments: RightClick in Composer  Note the *same* EIP in both rc1
and rc2     2004 May 18th  07h08  Version 1.7 rc2  MOZILLA caused an invalid
page fault in  module MSVCRT.DLL at 0177:7800d16a.  Registers:  EAX=00760008
CS=0177 EIP=7800d16a EFLGS=00010283 
     (50837)	Comments:  EBX=00000009 SS=017f ESP=0064e5bc EBP=0064e5d8 
ECX=00763dc4 DS=017f ESI=041650cc FS=5747  EDX=00000017 ES=017f EDI=0000001e
GS=0000  Bytes at CS:EIP:  8b 5c d1 04 8d 0c d1 89 5e 04 89 4e 08 89 71 04  
Stack dump:  00000000 00000100 04165170 00763dc4
     (50837)	Comments:  00000000 000000a0 00000180 0064e638 78011b77 00760138
041650cc 02520ef0 04165170 00000090 041189f4 0000003e     2004 May 17th  05h05 
Version 1.7 rc 1  MOZILLA caused an invalid page fault in  module MSVCRT.DLL at
0177:7800d16a.  Registers:  EAX=00770008
     (50837)	Comments:  CS=0177 EIP=7800d16a EFLGS=00010202  EBX=00770138
SS=017f ESP=0065f030 EBP=0065f04c  ECX=00773dc4 DS=017f ESI=053f179c FS=57ff 
EDX=00000010 ES=017f EDI=0000001e GS=0000  Bytes at CS:EIP:  8b 5c d1 04 8d 0c
d1 89 5e 04 89 4e 08 89 71 04   Stack dump: 
     (50837)	Comments:  00000000 00000200 053f17a0 00773dc4 00000001 00000121
00000110 0065f0ac 78011b77 00770138 053f18ac 05880df0 053f17a0 00000110 053feb90
0000007e   
 

Updated

14 years ago
Flags: blocking1.7?

Updated

14 years ago
Flags: blocking1.7? → blocking1.7+
accepting, but I haven't been able to make this happen yet.

does anyone have any steps to reproduce this?

Status: NEW → ASSIGNED

Comment 6

14 years ago
Incidents are Windows 98 only so people using Win 98 can help reproduce this.
One comment suggests that this is because of editing/writing mail while new
messages come in. I couldn't reproduce on Windows 2003.
Keywords: qawanted

Comment 7

14 years ago
Happens with me regularly at least once a week, on Win 2K Pro SP4, Happened with
WinXP (No service pack) also... usually happens when system has been running for
at least 4-5 hours, and mail has been open since quite some time, never ever
happened just after rebooting 

Comment 8

14 years ago
Easily recreatable, at least for me.  winXP home.  Started happening after
upgrading moz to nightly build 2004052307.  I did not have trouble with nightly
20040430.  I can't vouch for nightlies in between

Specifically:
1. ctrl-R reply to existing message - entire message is quoted
2. mouse select from end of quoted message back to a mid-point in the quoted message
3. delete selection
4. click at midpoint of remaining message (I chose a 'blank' line)
5. backspace
6. crash

BTW, this is a killer bug for me.
wayne, can you attach the message that you use to crash?  (save it to disk as an
.eml and attach the .eml file)

if you'd prefer not to do that, could you send me the message (fwd as attachment)

also, do you:

1) compose in plain or html?
2) do you use a signature?
3) have any other non-default settings (for your identities or for mail compose)

Updated

14 years ago
Whiteboard: investigating
I've tried steps from wayne, no luck yet.

if anyone else has steps please let me know.

Comment 11

14 years ago
Was happening for me Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2)
Gecko/20040523

updated and I am unable to recreate crash using Mozilla/5.0 (Windows; U; Windows
NT 5.1; en-US; rv:1.8a2) Gecko/20040527

Perhaps the bugger is bug 244576

you think this was a regression caused by
http://bugzilla.mozilla.org/show_bug.cgi?id=241058

Comment 13

14 years ago
Both bug 244576 and bug 239749 were fixed on trunk, so not possible for me to
say which fixed it, if it is indeed totally gone. 

Does problem exist in 1.7 and if so will fix be rolled in?

Comment 14

14 years ago
wayne, can you try a recent 1.7 build?

Comment 15

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040529 works
AFAICS (so does latest 1.8 trunk build).

re comment 13, my reference to bug 239749 is incorrect and I don't recall the
number of the bug I was thinking of
this is a dup, but I'm not sure which bug.  I'm going to mark as worksforme.

according to wayne, he no longer sees it on the trunk (and he doesn't see it on
1.7 final.)

jay, can you keep your eye on talkback (1.7 final and 1.8 trunk) to see if this
bug isn't really fixed?
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Whiteboard: investigating → appears to be [fixed by a checkin to another bug]

Comment 17

14 years ago
not blocking...  request again if it shows up on branch builds
Flags: blocking1.7+ → blocking1.7-

Comment 18

14 years ago
*** Bug 245362 has been marked as a duplicate of this bug. ***

Comment 19

14 years ago
This is still happening with 1.7rc3:
12   MSVCRT.DLL   3 
====================================================================================================
     Count   Offset    Real Signature
[ 1   MSVCRT.DLL + 0xd16a (0x7800d16a) 4d9e3a1a - MSVCRT.DLL + 0xd16a (0x7800d16a) ]
     Crash date range: 10-JUN-04 to 10-JUN-04
     Min/Max Seconds since last crash: 5514 - 5514
     Min/Max Runtime: 39037 - 39037
     Count   Platform List 
     1   [Windows 98 4.10 build 67766446]   
     Count   Build Id List 
     1   2004060810
     No of Unique Users         1
  Stack trace(Frame) 
	 MSVCRT.DLL + 0xd16a (0x7800d16a)  
	 MSVCRT.DLL + 0x11b77 (0x78011b77)  
	 nsVoidArray::SizeTo
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsVoidArray.cpp
 line 188] 
	 nsAutoVoidArray::SizeTo
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsVoidArray.cpp
 line 698] 
	 nsVoidArray::GrowArrayBy
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsVoidArray.cpp
 line 282] 
	 nsVoidArray::InsertElementAt
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsVoidArray.cpp
 line 397] 
	 InsertRuleByWeight
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/content/html/style/src/nsCSSStyleSheet.cpp
 line 4230] 
	 0xf84d10da  
	 0x36030674   

Comment 20

14 years ago
Experienced it as posted earlies, but after multiple attempts I can't recreate
crash with 1.7rc3  Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040608

Comment 21

14 years ago
(In reply to comment #20)
Wayne, please post your talkback ID here
Are you sure it was the same bug ?

Comment 22

14 years ago
(In reply to comment #19)
Sorry, this is not the same call stack so I'm not sure it was a crash writing
e-mail. 
There are several crashes at the same address within msvcrt.dll. It seems that C
rutime realloc() function crashes on Windows98 when called from different
places. Talkback data should tell if this is on low memory condition.
Product: MailNews → Core
Product: Core → MailNews Core
Crash Signature: [@ MSVCRT.DLL - nsVoidArray::SizeTo]
You need to log in before you can comment on or make changes to this bug.