Mozilla crashes if you request jre 1.3.1 instead of 1.3.1_*

RESOLVED INVALID

Status

--
critical
RESOLVED INVALID
15 years ago
8 years ago

People

(Reporter: seeger, Assigned: yuanyi21)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040316

If you have this in a website: 
 
<embed 
  id="soundappletElement" 
  name="soundapplet" 
  type="application/x-java-applet;version=1.3.1" 
  java_CODE="de.sitewaerts.scola.sound.applet.SoundPlayerApplet" 
  java_CODEBASE="../applets" 
  java_ARCHIVE="jorbis-0.0.12.jar,jogg-0.0.5.jar" 
  pluginspage="http://java.sun.com/j2se/1.3/download.html" 
  MAYSCRIPT="MAYSCRIPT"> 
</embed> 
 
Mozilla crashes with this, if you set 1.3.1_01 or something else like this in 
the version mozilla runs fine. 
 
Installed is the gcc3 plugin of 1.4.2_03. 
 
On console I get this: 
mozilla --g-fatal-warnings /var/www/test.html 
INTERNAL ERROR on Browser End: Exec of "java_vm" failed: 2 
< 
System error?:: No such file or directory 
 
** WARNING **: Serious fd usage error 18 
aborting... 
INTERNAL ERROR on Browser End: Could not read ack from child process 
System error?:: Resource temporarily unavailable 
 

Reproducible: Always
Steps to Reproduce:
1. copy the plugin file from jdk 1.4.2_03 to mozilla/plugins 
2. copy the embed example into a html file 
3. view the file with mozilla 
 
Actual Results:  
 

Expected Results:  
Not sure if it should execute the java app with 1.4 because there is no 1.3, 
but at least it shouldn't crash 

I was not able to reproduce this on Windows.
> 1. copy the plugin file from jdk 1.4.2_03 to mozilla/plugins 

don't do that, symlink the plugin isntead.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.