If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

JavaScript controlled QT plugin on Mac OS 9.2.2 causes Netscape 7.0x and Mozilla 1.2.1 to crash.

RESOLVED DUPLICATE of bug 157631

Status

Core Graveyard
Embedding: Mac
--
critical
RESOLVED DUPLICATE of bug 157631
14 years ago
a year ago

People

(Reporter: Steve Springett, Assigned: Conrad Carlen (not reading bugmail))

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.2.1) Gecko/20021130

* SUMMARY 
An embedded QuickTime player in a webpage in Netscape 7.0x or Mozilla 1.2.1 
will crash Netscape/Mozilla when JavaScript is used to control the player.



* REGRESSION
Tested with Netscape 7.02 and QuickTime 6.0.3, both of which are the latest 
available for OS 9.2.2.  Obtained/tested Mozilla 1.2.1, Netscape 7.0 and 7.01 
with same QuickTime version and problem persisted.

Reproducible: Always
Steps to Reproduce:
On Mac OS 9.2.2 with QuickTime 6.0.3 and Netscape 7.0 (including 7.0, 7.01 and 
7.02 and Mozilla 1.2.1).
Open the attached file in Netscape.
Click on the 'Step 1' link which simply uses Javascript to start playback.
Click on 'Step 3' which is mearly a hyperlink to www.apple.com.

Actual Results:  
Netscape will crash with the following message:

The application "Netscape" has unexpectedly quit, because an error of type 7 
occured.


Expected Results:  
Not crashed ;-)

The following HTML file will crash Netscape.

<html>
<head>
 <title>QuickTime Player - Test Page</title>
</head>
<body bgcolor="#FFFFFF">
<table width="400" height="300" cellpadding="0" cellspacing="0" border="1">
 <tr>
  <td>
   <object classid="clsid:02BF25D5-8C17-4B23-BC80-D3488ABDDC6B" 
codebase="http://www.apple.com/qtactivex/qtplugin.cab" width="400" 
height="300" id="MediaPlayer">
    <param name="src" value="http://www.ndmccc.com/ndm/data/quicktime.mov">
    <param name="qtsrc" value="rtsp://69.13.118.172:554/23221.mov">
    <param name="autoplay" value="false">
    <param name="controller" value="false">
    <param name="type" value="video/quicktime">
    <param name="movieid" value="123456">
    <param name="moviename" value="My Movie">
    <param name="kioskmode" value="true">
    <param name="loop" value="false">
    <param name="scale" value="aspect">

    <embed src="http://www.ndmccc.com/ndm/data/quicktime.mov"
      qtsrc="rtsp://69.13.118.172:554/23221.mov"
      width="400"
      height="300"
      autoplay="false"
      controller="false"
      type="video/quicktime"
      movieid="12345"
      moviename="My Movie"
      kioskmode="true"
      loop="false"
      scale="aspect"
      name="MediaPlayer"
      pluginspace="http://www.apple.com/quicktime/download/"
      enablejavascript="true">
    </embed>
   </object>
  </td>
 </tr>
 <tr>
  <td>
   <a href="javascript:document.MediaPlayer.Play();">Step 1 - Play 
Video</a><br>
   <a href="javascript:document.MediaPlayer.Stop();">Step 2 - Stop Video 
(optional)</a><br>
   <a href="http://www.apple.com/">Step 3 - Click a Hyperlink</a>
  </td>
 </tr>
</table>
</body>
</html>

*** This bug has been marked as a duplicate of 157631 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.